浙江大学 pat 题解---58

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

 

 

#include"iostream"

#include "string"
using namespace std;

struct Point
{
int a;
int b;
int c;
};
Point addto(Point s1, Point s2)
{
Point re;
re.c=0;
re.b=0;
re.a=0;
re.c=s1.c+s2.c;
if(re.c>=29)
{
re.c%=29;
re.b++;
}
re.b +=s1.b+s2.b;
if(re.b>=17)
{
re.b%=17;
re.a++;
}
re.a +=s1.a+s2.a;
return re;
}
int main()
{
char s1[15],s2[15];
Point st1;
Point st2;
Point result;
char ch;
cin>>s1;
cin>>s2;
sscanf(s1,"%d%c%d%c%d",&st1.a,&ch,&st1.b,&ch,&st1.c);
sscanf(s2,"%d%c%d%c%d",&st2.a,&ch,&st2.b,&ch,&st2.c);
result = addto(st1,st2);
cout<<result.a<<"."<<result.b<<"."<<result.c<<endl;

return 0;

}

转载于:https://www.cnblogs.com/luxiao/p/3272407.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值