【PAT】1059. Prime Factors (25)

题目链接:http://pat.zju.edu.cn/contests/pat-a-practise/1059

题目描述:

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

分析:(1)先建立素数组(2)要考虑输入为 1 的特例。


参考代码:

#include<iostream>
#include<cmath>
using namespace std;

#define max 1000
int prime[max];
int i;
int j;

bool isPrime(int temp)
{
	int t;
	bool flag = true;
	for(t = 2; t <= sqrt(temp); t++)
		if( temp%t == 0) {flag = false; break;}
	return flag;
}

int main()
{
	prime[0] = 2;
	j = 3;
	for(i=1; i<max; i++)
	{
		for(; j<100000; j++ )
		{
			if( isPrime(j) )
			{
				prime[i] = j++;
				break;
			}
		}
	}

	long input;
	int temp;
	int num;
	cin>>input;
	cout<<input<<"=";
	if(input == 1) //特例
		cout<<input;
	else
	{
		for(i=0; input != 1; i++)
		{
			num = 0;
			while( (input%prime[i]) == 0)
			{
				num++;
				input = input/prime[i];
			}
			if(num >= 1)
			{
				cout<<prime[i];
				if(num > 1)
					cout<<"^"<<num;
				if(input != 1)
					cout<<"*";
			}
		}
	}	
	cout<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值