Code Lock[HDU3461]

Code Lock
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2006 Accepted Submission(s): 766


Problem Description
A lock you use has a code system to be opened instead of a key. The lock contains a sequence of wheels. Each wheel has the 26 letters of the English alphabet 'a' through 'z', in order. If you move a wheel up, the letter it shows changes to the next letter in the English alphabet (if it was showing the last letter 'z', then it changes to 'a').
At each operation, you are only allowed to move some specific subsequence of contiguous wheels up. This has the same effect of moving each of the wheels up within the subsequence.
If a lock can change to another after a sequence of operations, we regard them as same lock. Find out how many different locks exist?

 

Input
There are several test cases in the input.

Each test case begin with two integers N (1<=N<=10000000) and M (0<=M<=1000) indicating the length of the code system and the number of legal operations.
Then M lines follows. Each line contains two integer L and R (1<=L<=R<=N), means an interval [L, R], each time you can choose one interval, move all of the wheels in this interval up.

The input terminates by end of file marker.

 

Output
For each test case, output the answer mod 1000000007

Sample Input
1 1
1 1
2 1
1 2

Sample Output
1
26

#include <stdio.h>
class Union_Find_Set {
#define MAX_UNION_FIND_SET_SIZE 10000010
public:
    int setSize;
    int father[MAX_UNION_FIND_SET_SIZE];
    Union_Find_Set() {
        setSize = 0;
    }
    Union_Find_Set(int x) {
        setSize = x;
        clear(x);
    }
    void clear(int x) {
        for (int i = 0; i < x; i++) {
            father[i] = i;
        }
    }
    int getFather(int x) {
        int ret = x, tmp;
        while (ret != father[ret]) {
            ret = father[ret];
        }
        while (x != father[x]) {
            tmp = father[x];
            father[x] = ret;
            x = tmp;
        }
        return ret;
    }
    bool merge(int a, int b) {
        a = getFather(a);
        b = getFather(b);
        if (a != b) {
            father[a] = b;
            return true;
        } else {
            return false;
        }
    }
    int countRoot() {
        int ret = 0;
        for (int i = 0; i < setSize; i++) {
            if (father[i] = i) {
                ret++;
            }
        }
        return ret;
    }
};
Union_Find_Set ufs;
__int64 quick_Mini(__int64 base, __int64 power, __int64 mod) {
    __int64 x = base, ret = 1;
    while (power) {
        if (power & 1) {
            ret *= x;
            ret %= mod;
        }
        power >>= 1;
        x *= x;
        x %= mod;
    }
    return ret;
}
int main() {
    int n, m, a, b, t;
    while (scanf("%d%d", &n, &m) != EOF) {
        ufs.clear(n + 1);
        t = 0;
        for (int i = 0; i < m; i++) {
            scanf("%d%d", &a, &b);
            if (ufs.merge(a - 1, b)) {
                t++;
            }
        }
        printf("%I64d\n", quick_Mini(26, n - t, 1000000007));
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/dramstadt/p/6224131.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值