B--Bookshelf 2

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

题目大意 : 有N头牛一个书架,书架太高要站在牛身上够书架,已知N头牛的高度和书架的高度,一头牛可以站在另一头牛身上,总高度是他们的高度之和,高度和需要不小于(大于等于均可)书架高度,问符合要求的最低高度是多少,输出该高度与书架高度的差值。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1005000
#define oo 0x3f3f3f
int a[N];
int dp[N];
int vis[N];
int n,p;
int main()///dp储存牛的高度和,背包容量 v 为所有牛的高度总和,价值和体积就是每头牛的高度。

{

    int t;
    int n,b;
    while(scanf("%d%d",&n,&b)!=EOF)
    {
        int sum = 0;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        int Min = oo;
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j>=a[i];j--)
            {
                dp[j] = max(dp[j],dp[j-a[i]]+a[i]);
                if(dp[j]>=b)///是大于等于
                {
                    Min = min(Min,dp[j]);
                }
            }
        }
        printf("%d\n",Min-b);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/biu-biu-biu-/p/5741313.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值