B - Bookshelf 2(01背包简单变形)

题目描述

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1
题意:

给你N个奶牛的高度,问你把这些奶牛重叠在一起,并且高度大于M。且高度是所有方法中最小的方法。输出最小高度减去M。

分析:

我们可以先跑一遍01背包。我们在跑01背包的时候能得到每个值。于是,可以在得到每个值得同时判断是否大于M,并且小于之间的最小高度。
AC 代码:

#include"stdio.h"
#include"string.h"
#include"functional"
#include"iostream"
#include"algorithm"
   using namespace std;
typedef long long ll;
#define scanll(a,b) scanf("%I64d%I64d",&a,&b);
#define scanl(a) scanf("%I64d",&a);
#define scanff(a,b) scanf("%lf%lf",&a,&b);
#define scan1f(a) scanf("%lf",&a);
#define prinll(a,b) printf("%I64d %I64d",a,b);
#define prinl(a) printf("%I64d",a);
#define printff(a,b) printf("%lf %lf",a,b);
#define printlf(a) printf("%lf",a);
#define OK printf("\n");
#define MAXSIXE 310
ll dp[1000010];
int main()
{
    ll N,M;
    ll h[21];
    ll sum=0;
    scanll(N,M);
    for(ll i=1;i<=N;i++)
        {
            scanl(h[i]); sum+=h[i];
        }
    ll ans=1000100;
    memset(dp,0,sizeof(dp));
    for(ll i=1;i<=N;i++)
    {
        for(ll j=sum;j>=h[i];j--)
        {
            dp[j]=max(dp[j],dp[j-h[i]]+h[i]);
            if(dp[j]>=M&&ans>dp[j])
                ans=dp[j];
        }
    }
    printf("%lld\n",ans-M);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值