Judging Troubles (multiset查找) 分类: ...

Judging Troubles
Time Limit: 5000ms, Special Time Limit:12500ms, Memory Limit:65536KB
Total submit users: 91, Accepted users: 72
Problem 13352 : No special judgement
Problem description

The NWERC organisers have decided that they want to improve the automatic grading of the submissions for the contest, so they now use two systems: DOMjudge and Kattis. Each submission is judged by both systems and the grading results are compared to make sure that the systems agree. However, something went wrong in setting up the connection between the systems, and now the jury only knows all results of both systems, but not which result belongs to which submission! You are therefore asked to help them figure out how many results could have been consistent.

Input

The input consists of:

• one line with one integer n (1 ≤ n ≤ 10^5), the number of submissions;

• n lines, each with a result of the judging by DOMjudge, in arbitrary order;

• n lines, each with a result of the judging by Kattis, in arbitrary order.

Each result is a string of length between 5 and 15 characters (inclusive) consisting of lowercase letters.

Output

Output one line with the maximum number of judging results that could have been the same for both systems.

Sample Input
5
correct
wronganswer
correct
correct
timelimit
wronganswer
correct
timelimit
correct
timelimit

Sample Output
4

Problem Source
NWERC 2014
题意就是看看给出的两个评测系统的n的结果,让你求有多少个是相同的提交。
用multiset,也可以用map做

#include<stdio.h>
#include<string.h>
#include<set>
#include<vector> 
#include<algorithm>
#include<iostream>
#include<string>
#include<stdlib.h> 
#define maxn 100000+100 
using namespace std;
char str[maxn];
char ch[maxn];
string ss;
int main()
{
    int n;
    multiset<string>S;
    scanf("%d",&n);
    getchar();
    for(int i=0;i<n;i++)
    {
       scanf("%s",str);
        S.insert(str);
    }
    //printf("%d\n",S.size());
    int count=0;
    for(int i=0;i<n;i++)
    {
        scanf("%s",ch);
        multiset<string>::iterator it;
        it=S.find(ch);
        if(it!=S.end())
        {
            count++;
            S.erase(it);
        }    
    }
    printf("%d\n",count);
    return 0;
}
//map版本
#include<stdio.h>
#include<string.h>
#include<set>
#include<vector>
#include<algorithm>
#include<iostream>
#include<string>
#include<stdlib.h>
#include<map>
#define maxn 100000+100
using namespace std;
char str[maxn];
char ch[maxn];
string ss;
int main()
{
    int n;
    map<string,int>S;
    S.clear();
    scanf("%d",&n);
    getchar();
    for(int i=0;i<n;i++)
    {

        scanf("%s",str); 
        S[str]++;
    }
    //printf("%d\n",S.size());
    int count=0;
    for(int i=0;i<n;i++)
    {
        scanf("%s",ch) ;
        if(S[ch]>0)
        {
            count++;
            S[ch]--; 
        }
    }
    printf("%d\n",count);
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/NaCl/p/4700582.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值