UVAlive 6959 Judging hash

该博客分析了UVa在线判题系统中的一道题目,涉及判断提交答案的正确性。博主探讨了如何处理两个不同判题系统返回的结果,寻找相同结果的最大数量。问题转化为计算两个集合中相同字符串的对数,解决方案包括使用哈希处理和映射记录。给出了AC代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Judging

Time Limit: 20 Sec  Memory Limit: 256 MB

题目连接

http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=114147

Description

The NWERC organisers have decided that they want to improve the automatic grading of the submissions for the contest, so they now use two systems: DOMjudge and Kattis. Each submission is judged by both systems and the grading results are compared to make sure that the systems agree. However, something went wrong in setting up the connection between the systems, and now the jury only knows all results of both systems, but not which result belongs to which submission! You are therefore asked to help them figure out how many results could have been consistent.

Input

The input consists of:

    one line with one integer n (1≤n≤105), the number of submissions;
    n lines, each with a result of the judging by DOMjudge, in arbitrary order;
    n lines, each with a result of the judging by Kattis, in arbitrary order.

Each result is a string of length between 5 and 15 characters (inclusive) consisting of lowercase letters.


Output

Output one line with the maximum number of judging results that could have been the same for both systems.

 

Sample Input

5
correct
wronganswer
correct
correct
timelimit
wronganswer
correct
timelimit
correct
timelimit

Sample Output

4

题意:两个集合,每个集合分别N个字符串,每个集合相同的算一对,问有多少对。

题解:hash处理然后map记录即可,也可以直接mao存string,hash得双hash,会卡BKDRHash。

AC代码:

/*
* @Author: 王文宇
* @Date:   2018-06-26 01:37:59
* @Last Modified by:   王文宇
* @Last Modified time: 2018-06-26 02:04:40
*/
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100006;
#define _for(i,a,b) for(int i=a;i<=b;i++)
typedef long long ll;
typedef pair<int,int> P;
int n;
map<P,int> Q;
int get_hash(char *key)
{
    ll N=1998585857;
    long long h=0;
    while(*key)
        h=(h*127+(*key++)+N)%N;
    return h%N;
}
int get_hash2(char *key)
{
    ll N=127398127;
    long long h=0;
    while(*key)
        h=(h*127+(*key++)+N)%N;
    return h%N;
}
int main(int argc, char const *argv[])
{
	while(scanf("%d",&n)!=EOF)
	{
		Q.clear();
		_for(i,1,n)
		{
			char s[20];
			P p;
			cin>>s;
			p.first = get_hash(s);
			p.second = get_hash2(s);
			Q[p]++;
		}
		int ans = 0;
		_for(i,1,n)
		{
			char s[20];
			P p;
			cin>>s;
			p.first = get_hash(s);
			p.second = get_hash2(s);
			if(Q[p]>0)
			{
				Q[p]--;
				ans++;
			}
		}
		cout<<ans<<endl;		
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值