【POJ 1821】Fence

Fence
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6933 Accepted: 2309

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct. 

Being the team's leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income. 

Write a program that determines the total maximal income obtained by the K workers. 

Input

The input contains: 
Input 

N K 
L1 P1 S1 
L2 P2 S2 
... 
LK PK SK 

Semnification 

N -the number of the planks; K ? the number of the workers 
Li -the maximal number of planks that can be painted by worker i 
Pi -the sum received by worker i for a painted plank 
Si -the plank in front of which sits the worker i 

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4
3 2 2
3 2 3
3 3 5
1 1 7 

Sample Output

17

Hint

Explanation of the sample: 

the worker 1 paints the interval [1, 2]; 

the worker 2 paints the interval [3, 4]; 

the worker 3 paints the interval [5, 7]; 

the worker 4 does not paint any plank 

Source

题解:先来见证一下没有单调队列优化的DP

          (我自己测了两组数据对拍都没有问题,一提交POJ就WA,哭了,明明应该TLE的。。。)

#include<iostream>
#include<algorithm>
#include<queue>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
const int N=20002;
int k,n;
struct node{
    int l,p,s;
}a[105];
int dp[103][N],ans;
bool cmp(node aa,node bb){
    return aa.s<bb.s;
}
//dp[i][j]表示前i个工人,前j个篱笆的最大获利
void work_jjj(){
    memset(dp,0,sizeof(dp)); ans=0;
    for(int i=1;i<=k;i++)
        scanf("%d %d %d",&a[i].l,&a[i].p,&a[i].s);
    sort(a+1,a+k+1,cmp);
    //粉刷的最大范围,粉刷完的获利,工人的位置 
    for(int i=1;i<=k;i++){//前i个工人 
        for(int j=1;j<=n;j++){//前i个工人粉刷完成到了j板 
            dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            //前i-1个粉刷匠完成前j个木板的工作
            //前i个粉刷匠完成前j-1个木板的工作 
            if(j<a[i].s) continue;
            for(int k=1;k<=a[i].s;k++){
                if(k+a[i].l<j) continue;
                dp[i][j]=max(dp[i][j],dp[i-1][k]+a[i].p*(j-k));
            }
            //前i-1个粉刷匠完成前k个木板的工作
            //从k+1~j的木板由第i个工匠来粉刷 
        }
    }
    //for(int i=1;i<=k;i++)
    //    ans=max(ans,dp[i][n]); 
    printf("%d\n",dp[k][n]);
}
int main(){
    freopen("1821.in","r",stdin);
    freopen("1821.out","w",stdout);
    while(scanf("%d %d",&n,&k)!=EOF)
        work_jjj(); 
    return 0;
}

 

转载于:https://www.cnblogs.com/wuhu-JJJ/p/11337036.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值