c++堆栈实现

A Stack is a data-structure that
You can only add an element to the top of the Stack, and
You can only read or remove an element also from the top.
Please use a vector to implement a Stack

EXAMPLE INPUT
1 2 3 4 5 6 7 8 9EXAMPLE OUTPUT
9 8 7 6 5 4 3 2 1


主程序

#include <vector>
using namespace std;

class EmptyStackException {};

template <typename E>
class Stack
{
private:
vector<E> elements;

public:

void addFirst(const E & elem);
E removeFirst();
};

#include "source"

#include <iostream>
using namespace std;
代写
int main() {
Stack<int> stack;
for (int i = 0; i < 9; ++ i) {
int value;
cin >> value;
stack.addFirst(value);
}
for (int i = 0; i < 9; ++ i) {
cout << stack.removeFirst() << " ";
}
}

转载于:https://www.cnblogs.com/oversea201405/p/3752737.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值