HDU 5384——Danganronpa——————【AC自动机】

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 582    Accepted Submission(s): 323


Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are  n verbal evidences, and Stilwell has m "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings Ai, and bullets are some strings Bj. The damage to verbal evidence Ai from the bullet Bj is f(Ai,Bj).
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words, f(A,B) is equal to the times that string B appears as a substring in string A.
For example: f(ababa,ab)=2f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence Ai after shooting all m bullets Bj, in other words is mj=1f(Ai,Bj).
 

 

Input
The first line of the input contains a single number  T, the number of test cases.
For each test case, the first line contains two integers nm.
Next n lines, each line contains a string Ai, describing a verbal evidence.
Next m lines, each line contains a string Bj, describing a bullet.

T10
For each test case, n,m1051|Ai|,|Bj|104|Ai|105|Bj|105
For all test case, |Ai|6105|Bj|6105Ai and Bj consist of only lowercase English letters
 

 

Output
For each test case, output  n lines, each line contains a integer describing the total damage of Ai from all m bullets, mj=1f(Ai,Bj).
 

 

Sample Input
1
5 6
orz
sto
kirigiri
danganronpa
ooooo
o
kyouko
dangan
ronpa
ooooo
ooooo
 

 

Sample Output
1
1
0
3
7
 
 
题目大意:t组测试数据,下面有n个文本串,m个模式串,问每个文本串能匹配多少个模式串。
 
解题思路:AC自动机,记录模式串单词出现的次数cnt,然后直接套模板就可以了。
 
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+200;
char Text[maxn][maxn/10],Pattern[maxn];
struct ACnode{
    ACnode *fail;
    ACnode *next[26];
    int cnt;
    ACnode (){
        fail=NULL;
        for(int i=0;i<26;i++)
            next[i]=NULL;
    }
}*Q[maxn*10];
ACnode *newacnode(){
    ACnode *tmp;
    tmp=new ACnode;
    tmp->cnt=0;
}
void Insert(ACnode *rt,char *s){
    int len=strlen(s);
    int idx;
    for(int i=0;i<len;i++){
        idx=s[i]-'a';
        if(rt->next[idx]==NULL){
            rt->next[idx]=newacnode();
        }
        rt=rt->next[idx];
    }
    rt->cnt++;
}
void BuildAC(ACnode *root){
    int head,tail;
    head=tail=0;
    for(int i=0;i<26;i++){
        if(root->next[i]!=NULL){
            root->next[i]->fail=root;
            Q[tail++]=root->next[i];
        }
    }
    ACnode *p,*tmp;
    while(head!=tail){
        p=Q[head++];
        tmp=NULL;
        for(int i=0;i<26;i++){
            if(p->next[i]!=NULL){
                tmp=p->fail;
                while(tmp!=NULL){
                    if(tmp->next[i]!=NULL){
                        p->next[i]->fail=tmp->next[i];
                        break;
                    }
                    tmp=tmp->fail;
                }
                if(tmp==NULL){
                    p->next[i]->fail=root;
                }
                Q[tail++]=p->next[i];
            }
        }
    }
}
int Query(ACnode *root,char *str){
    ACnode *p=root,*tmp=NULL;
    int idx,len,ret;
    ret=0;
    len=strlen(str);
    for(int i=0;i<len;i++){
        idx=str[i]-'a';
        while( p->next[idx]==NULL && p!=root  )
            p=p->fail;
        p=p->next[idx];
        if(p == NULL)
            p=root;
        tmp=p;
        while(tmp!=root ){
            ret+=tmp->cnt;
            tmp=tmp->fail;
        }
    }
    return ret;
}

int main(){
    int n,m,t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        ACnode *root;
        root=newacnode();
        for(int i=0;i<n;i++){
            scanf("%s",Text[i]);
        }
        for(int i=0;i<m;i++){
            scanf("%s",Pattern);
            Insert(root,Pattern);
        }
        BuildAC(root);
        for(int i=0;i<n;i++){
            int ans=Query(root,Text[i]);
            printf("%d\n",ans);
        }
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/chengsheng/p/4735271.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值