hdu 5384 Danganronpa(AC自动机)

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1154    Accepted Submission(s): 594


Problem Description
Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are  n  verbal evidences, and Stilwell has  m  "bullets". Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings  Ai , and bullets are some strings  Bj . The damage to verbal evidence  Ai  from the bullet  Bj  is  f(Ai,Bj) .
f(A,B)=i=1|A||B|+1[ A[i...i+|B|1]=B ]
In other words,  f(A,B)  is equal to the times that string  B  appears as a substring in string  A .
For example:  f(ababa,ab)=2 f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence  Ai  after shooting all  m  bullets  Bj , in other words is  mj=1f(Ai,Bj) .
 

Input
The first line of the input contains a single number  T , the number of test cases.
For each test case, the first line contains two integers  n m .
Next  n  lines, each line contains a string  Ai , describing a verbal evidence.
Next  m  lines, each line contains a string  Bj , describing a bullet.

T10
For each test case,  n,m105 1|Ai|,|Bj|104 |Ai|105 |Bj|105
For all test case,  |Ai|6105 |Bj|6105 Ai  and  Bj  consist of only lowercase English letters
 

Output
For each test case, output  n  lines, each line contains a integer describing the total damage of  Ai  from all  m  bullets,  mj=1f(Ai,Bj) .
 

Sample Input
  
  
1 5 6 orz sto kirigiri danganronpa ooooo o kyouko dangan ronpa ooooo ooooo
 

Sample Output
  
  
1 1 0 3 7

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <queue>
#include<vector>
#include<string>
using namespace std;
const int maxn = 1e5*5 + 200;
struct Trie
{
    int next[maxn][26], fail[maxn], end[maxn],ans[maxn];
    int root, L;
    int newnode()
    {
        for (int i = 0; i < 26; i++)
            next[L][i] = -1;
        end[L++] = 0;
        return L - 1;
    }
    void init()
    {
        L = 0;
        memset(ans, 0, sizeof(ans));
        root = newnode();
    }
        void insert(char buf[])
    {
        int len = strlen(buf);
        int now = root;
        for (int i = 0; i < len; i++)
        {
            if (next[now][buf[i] - 'a'] == -1)
                next[now][buf[i] - 'a'] = newnode();
            now = next[now][buf[i] - 'a'];
        }
        end[now]++;
    }
    void build()
    {
        queue<int>Q;
        fail[root] = root;
        for (int i = 0; i < 26; i++)
            if (next[root][i] == -1)
                next[root][i] = root;
            else
            {
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        while (!Q.empty())
        {
            int now = Q.front();
            Q.pop();
            for (int i = 0; i < 26; i++)
                if (next[now][i] == -1)
                    next[now][i] = next[fail[now]][i];
                else
                {
                    fail[next[now][i]] = next[fail[now]][i];
                    Q.push(next[now][i]);
                }
        }
    }
    void query(string buf,int id)
    {
        int len = buf.size();
        int now = root;
        for (int i = 0; i < len; i++)
        {
            now = next[now][buf[i] - 'a'];
            int temp = now;
            while (temp != root)
            {
                ans[id] += end[temp];
                temp = fail[temp];
            }
        }
    }
};
Trie ac;
vector<string>que;
char buf[maxn];
string s;
int main()
{
    int T;
    int n,m;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n,&m);
        ac.init();
        que.clear();
        for (int i = 0; i < n; i++)
        {
            cin >> s;
            que.push_back(s);
        }
        for (int i = 0; i < m; i++)
        {
            scanf("%s", buf);
            ac.insert(buf);
        }
        ac.build();
        for (int i = 0; i < n; i++)
            ac.query(que[i], i);
        for (int i = 0; i < n; i++)
            printf("%d\n", ac.ans[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值