hdu 2276(矩阵快速幂)

Kiki & Little Kiki 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2301    Accepted Submission(s): 1176


Problem Description
There are n lights in a circle numbered from 1 to n. The left of light 1 is light n, and the left of light k (1< k<= n) is the light k-1.At time of 0, some of them turn on, and others turn off. 
Change the state of light i (if it's on, turn off it; if it is not on, turn on it) at t+1 second (t >= 0), if the left of light i is on !!! Given the initiation state, please find all lights’ state after M second. (2<= n <= 100, 1<= M<= 10^8)

 

Input
The input contains one or more data sets. The first line of each data set is an integer m indicate the time, the second line will be a string T, only contains '0' and '1' , and its length n will not exceed 100. It means all lights in the circle from 1 to n.
If the ith character of T is '1', it means the light i is on, otherwise the light is off.

 

Output
For each data set, output all lights' state at m seconds in one line. It only contains character '0' and '1.
 

Sample Input
 
  
1 0101111 10 100000001
 

Sample Output
 
  
1111000 001000010
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1757 1588 2604 2256 2294 

/*
  能够把转换关系找出来的话,这题就是个比较裸的快速幂了
  用a[i]*代表上一层的a[i],通过推样例会发现如下规律:
  a[i]=(a[i]*+a[i-1]*)%2,其中a[1]=(a[1]*a[n]*)%2
  
  第一次敲快速幂,存做模板

*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <set>
#include <cmath>
#include <vector>
#include<cstdlib>
#define INF 1<<30
#pragma comment (linker,"/STACK:102400000,102400000")
using namespace std;
#define maxn 150
#define moo 2
char s[maxn];
int n,m;
struct Mat
{
    int a[maxn][maxn];
};
Mat res1;
Mat muti(Mat a,Mat b)
{
    Mat res;
    memset(res.a,0,sizeof(res.a));
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
    {
       for(int k=0;k<n;k++)
            res.a[i][j]=(res.a[i][j] + a.a[i][k]*b.a[k][j])%moo;
    }
    return res;
}
Mat pow(Mat res,int m)
{
    Mat ss;
    memset(ss.a,0,sizeof(ss.a));
    for(int i=0;i<n;i++)
        ss.a[i][i]=1;
    while(m)
    {
        if(m%2)
        ss=muti(ss,res);
        res=muti(res,res);
        m/=2;
    }
    return ss;
}
int main()
{
    int ans[maxn];
    Mat oo;
    while(~scanf("%d",&m))
    {
        scanf("%s",s);
        n=strlen(s);
        for(int i=0;i<n;i++)
        ans[i]=s[i]-'0';
        int ant[maxn];
        memset(ant,0,sizeof(ant));
        memset(res1.a,0,sizeof(res1.a));

        res1.a[0][0]=res1.a[n-1][0]=res1.a[n-1][n-1]=1;
        for(int i=0;i<n-1;i++)
            res1.a[i][i]=res1.a[i][i+1]=1;
        oo=pow(res1,m);

        for(int j=0;j<n;j++)
            for(int i=0;i<n;i++)
            ant[j]=(ant[j]+ans[i]*oo.a[i][j])%moo;
            for(int i=0;i<n;i++)
                cout<<ant[i];
            cout<<endl;
    }
    return 0;
}



转载于:https://www.cnblogs.com/zhanpang/p/5682882.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值