hdu 2276 Kiki & Little Kiki 2(矩阵快速幂)

Kiki & Little Kiki 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1494    Accepted Submission(s): 755


Problem Description
There are n lights in a circle numbered from 1 to n. The left of light 1 is light n, and the left of light k (1< k<= n) is the light k-1.At time of 0, some of them turn on, and others turn off. 
Change the state of light i (if it's on, turn off it; if it is not on, turn on it) at t+1 second (t >= 0), if the left of light i is on !!! Given the initiation state, please find all lights’ state after M second. (2<= n <= 100, 1<= M<= 10^8)

 

Input
The input contains one or more data sets. The first line of each data set is an integer m indicate the time, the second line will be a string T, only contains '0' and '1' , and its length n will not exceed 100. It means all lights in the circle from 1 to n.
If the ith character of T is '1', it means the light i is on, otherwise the light is off.

 

Output
For each data set, output all lights' state at m seconds in one line. It only contains character '0' and '1.
 

Sample Input
  
  
1 0101111 10 100000001
 

Sample Output
  
  
1111000 001000010
 

Source
 

Recommend
lcy


solve:矩阵快速幂


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct mat{
    int a[103][103];
}res,e;
char s[105];
long long m;
int c[105],cc[105],l;
void init()
{
    int i;

    memset(res.a,0,sizeof(res.a));
    memset(e.a,0,sizeof(e.a));
    for(i=0;i<l;i++) e.a[i][i]=e.a[(i-1+l)%l][i]=1;
    for(i=0;i<l;i++) res.a[i][i]=1;
}
struct mat mult(struct mat x,struct mat y)
{
    int i,j,k;
    struct mat temp;

    memset(temp.a,0,sizeof(temp.a));
    for(i=0;i<l;i++)
    {
        for(j=0;j<l;j++)
        {
            for(k=0;k<l;k++)
            temp.a[i][j]^=x.a[i][k]&y.a[k][j];
        }
    }
    return temp;
}
void solve()
{
    while(m)
    {
        if(m&1) res=mult(res,e);
        e=mult(e,e);
        m=m>>1;
    }
}
int main()
{
    int i,j;

    //freopen("t","r",stdin);
    while(scanf("%lld",&m)>0)
    {
        scanf("%s",s);
        l=strlen(s);
        for(i=0;i<l;i++) c[i]=s[i]-'0';
        init();solve();

        for(i=0;i<l;i++)
        {
            for(cc[i]=j=0;j<l;j++)
                cc[i]^=res.a[j][i]&c[j];
        }
        for(i=0;i<l;i++) printf("%d",cc[i]);
        printf("\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值