poj 3020 Antenna Placement (二分图)

Antenna Placement
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4520 Accepted: 2229

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

和上一道题很相似
在输入和最后的答案处理上需要加工一下
别的没啥了
#include<iostream>
using namespace std;
const int N = 500;
const int M = 28000;
int map[N][N];
char input[N][N];
int father[M];
int mark[M];
int num;
struct node
{
    int a,b;
};
node list[M];

int dfs(int a)
{
    for(int i=1;i<=num;i++)
    {
        if(map[a][i]==1 && mark[i]==0)
        {
            mark[i]=1;
            if(father[i]==0 || dfs(father[i]))
            {
                father[i]=a;
                return 1;
            }
        }
    }
    return 0;
}

int hung()
{
    int count = 0;
    memset(father, 0, sizeof(father));
    for(int i=1; i<=num;i++)
    {
        memset(mark, 0, sizeof(mark));
        if(dfs(i)==1)
            count++;
    }
    return count;
}

int main()
{
    int h,w;
    int t;
//    freopen("e:\\data.txt", "r", stdin);   
//    freopen("e:\\out.txt", "w", stdout);
    cin>>t;
    while(t--)
    {
        cin>>h>>w;
        num=0;
        for(int i=0;i<h;i++)
        {
            cin>>input[i];
        }
        for(int i=0;i<h;i++)
        {
            for(int j=0;j<w;j++)
            {
                if(input[i][j]=='*')
                {
                    num++;
                    list[num].a=i;
                    list[num].b=j;            
                }
            }
        }
        memset(map, 0, sizeof(map));
        for(int i=1;i<=num;i++)
        {
            for(int j=1;j<=num;j++)
            {
                if(abs(list[i].a-list[j].a)+abs(list[i].b-list[j].b)==1)
                {
                    map[i][j]=1;
                }
            }
        }
        cout<<num-hung()/2<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/w0w0/archive/2012/06/05/2537331.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值