POJ 2127 Greatest Common Increasing Subsequence -- 动态规划

题目地址:http://poj.org/problem?id=2127

Description

You are given two sequences of integer numbers. Write a program to determine their common increasing subsequence of maximal possible length.
Sequence S 1 , S 2 , . . . , S N of length N is called an increasing subsequence of a sequence A 1 , A 2 , . . . , A M of length M if there exist 1 <= i 1 < i 2 < . . . < i N <= M such that S j = A ij for all 1 <= j <= N , and S j < S j+1 for all 1 <= j < N .

Input

Each sequence is described with M --- its length (1 <= M <= 500) and M integer numbers A i (-2 31 <= A i < 2 31 ) --- the sequence itself.

Output

On the first line of the output file print L --- the length of the greatest common increasing subsequence of both sequences. On the second line print the subsequence itself. If there are several possible answers, output any of them.

Sample Input

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2
1 4


状态dp[i][j]表示seq1[i]从1到i与seq2[j]从1到j并以j为结尾的LCIS的长度

状态转移方程:

dp[i][j] = max(dp[i][k]) + 1, if seq1[i] ==seq2[j], 1 <= k  < j

dp[i][j] = dp[i-1][j], if seq1[i] != seq2[j]


#include <stdio.h>
#include <string.h>

#define MAX 501

typedef struct path{
	int x, y;
}Pre;

int seq1[MAX], seq2[MAX];
int len1, len2;
int dp[MAX][MAX]; //状态dp[i][j]记录seq1前i个与seq2前j个并以seq2[j]为结尾的LCIS的长度
Pre pre[MAX][MAX];//pre[i][j]记录前驱
int path[MAX];//根据pre[i][j]回溯可得到LCIS
int index;

int LCIS(){
	int i, j;
	int max, tx, ty;
	int id_x, id_y;
	int tmpx, tmpy;
	//给dp[i][j]、pre[i][j]置初值
	memset(dp, 0, sizeof(dp));
	memset(pre, 0, sizeof(pre));
	for (i = 1; i <= len1; ++i){
		max = 0;
		tx = ty = 0;
		for (j = 1; j <= len2; ++j){
			//状态转移方程
			dp[i][j] = dp[i-1][j];
			pre[i][j].x = i - 1;
			pre[i][j].y = j;
			if (seq1[i] > seq2[j] && max < dp[i-1][j]){
				max = dp[i-1][j];
				tx = i - 1;
				ty = j;
			}
			if (seq1[i] == seq2[j]){
				dp[i][j] = max + 1;
				pre[i][j].x = tx;
				pre[i][j].y = ty;
			}
		}
	}
	//找到LCIS最后的数字的位置
	max = -1;
	for (i = 1; i <= len2; ++i){
		if (dp[len1][i] > max){
			max = dp[len1][i];
			id_y = i;
		}
	}
	id_x = len1;
	index = 0;
	while (dp[id_x][id_y] != 0){
		tmpx = pre[id_x][id_y].x;
		tmpy = pre[id_x][id_y].y;
		//若找到前一对公共点,则添加进路径
		if (dp[tmpx][tmpy] != dp[id_x][id_y]){
			path[index] = seq2[id_y];
			++index;
		}
		id_x = tmpx;
		id_y = tmpy;
	}
	return max;
}

int main(void){
	int i;
	while (scanf("%d", &len1) != EOF){
		for (i = 1; i <= len1; ++i)
			scanf("%d", &seq1[i]);
		scanf("%d", &len2);
		for (i = 1; i <= len2; ++i)
			scanf("%d", &seq2[i]);

		printf("%d\n", LCIS());
		--index;
		if (index >= 0)
			printf("%d", path[index]);
		for (i = index - 1; i >= 0; --i){
			printf(" %d", path[i]);
		}
		printf("\n");
	}

	return 0;
}


转载于:https://www.cnblogs.com/liushaobo/p/4373760.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值