Greatest Common Increasing Subsequence (最长公共上升子序列的长度)

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题意:求两个序列的最长公共上升子序列的长度。

思路:dp[ j ] 记录在第一个数组的第 i 项时,第二个数组的第 j 项能达到的最长公共上升子序列的长度。滚动更新,最后求dp的最大值即可。

代码如下:

#include<cstdio>
#include<cstring>
int main()
{
    long long s[550],t[550];
    int dp[550];
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        int m,n;
        scanf("%d",&m);
        for(int i=0;i<m;i++)
            scanf("%lld",&s[i]);
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%lld",&t[i]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<m;i++)   //以s数组为比照,选定一个数依次和t内值比较
        {
            int maxx=0;       //这个位置可能达到的最大值
            for(int j=0;j<n;j++)
            {
                if(s[i]>t[j]&&dp[j]>maxx)  //更新最大长度,但要满足选定的这个数大于此时的数,突出上升子序列
                    maxx=dp[j];
                if(s[i]==t[j])             //得到公共数的时候,maxx+1
                    dp[j]=maxx+1;
            }
        }
        int maxx=0;
        for(int i=0;i<n;i++)
            if(dp[i]>maxx)   //求最大长度
                maxx=dp[i];
        printf("%d\n",maxx);
        if(tt)
            printf("\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值