hdu 2069 限制个数的母函数(普通型)

 

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17266    Accepted Submission(s): 5907


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
 
   
11 26
 

Sample Output
 
   
4 13
 

Author
Lily
 
题意: 能不能用1 5 10 25 50 组成输入的数,并且使用的个数不能超过100个。
 
思路:
多加一维维护个数。a[j][l] 表示值为j,用了l个的时候有多少种方案。
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define INF 1000000001
#define MOD 1000000007
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define pi acos(-1.0)
using namespace std;
const int MAXN = 300;
int c[MAXN][105],tp[MAXN][105],n,val[6];
int main()
{
    val[1] = 1,val[2] = 5,val[3] = 10,val[4] = 25,val[5] = 50;
    while(~scanf("%d",&n)){
        if(!n){
            puts("1");
            continue;
        }
        memset(c,0,sizeof(c));
        memset(tp,0,sizeof(tp));
        for(int i = 0; i <= min(n,100); i++){
            c[i][i] = 1;
        }
        for(int i = 2; i <= 5; i++){
            for(int j = 0; j <= n; j++){
                for(int k = 0; k + j <= n; k += val[i]){
                    for(int l = 0; l + k / val[i] <= 100; l ++){
                        tp[j + k][l + k / val[i]] += c[j][l];
                    }
                }
            }
            for(int j = 0; j <= n; j++){
                for(int k = 0; k <= 100; k++){
                    c[j][k] = tp[j][k];
                    tp[j][k] = 0;
                }
            }
        }
        int ans = 0;
        for(int i = 1; i <= 100; i++){
            ans += c[n][i];
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/sweat123/p/5515414.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值