浙大1018 Be carefull

浙大1018 Be carefull

Be carefull
Time Limit:1000MS  Memory Limit:32768K


Description:
“Be carefull about the precision!”When Tyr doing his mathemetic homework,teacher Mr.Qian always giving this warning to him.Now,Tyr has finished his mathemetic homework,and here is your task to check whether Tyr’s answer is correct or not.

Input:
The input consist of several cases.The first line gives the case number N, the next part has N cases.Each case is consist of two number R and I.R is a real number; I is an integer number.
Output:
For each case please give your check.If R rounds to I,then print “Correct” in a single line, or,print “Not Correct”.For more detail,please look at the samples.
Sample Input:
5
1.20 1
0.5 1
9.9 10
2.9 2
3.4999 3Sample Output:
Correct
Correct
Correct
Not Correct
Correct

解答:(实质就是一个四舍五入的题)
#include <iostream>
#include <string>
using namespace std;
int main()
{
 int a,t,T,tmp;
 double s;
 scanf("%d",&T);
 while(T--)
 {
  scanf("%lf%d",&s,&a);
  s=s*10;
  tmp=s;
  t=tmp%10;
  tmp/=10;
  if(t>4) tmp+=1;
  if(tmp==a) printf("Correct\n");
  else printf("Not Correct\n");
 }
 return 0;
}

转载于:https://www.cnblogs.com/qnbs1/articles/1691073.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值