十九届 浙大 校赛 A题 Thanks, TuSimple!

题目链接:

http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5969

Thanks, TuSimple!


Time Limit: 1 Second      Memory Limit: 65536 KB


In the very first sentence of the very first problem, we would like to give our sincere thanks to TuSimple, the sponsor of this contest.

Founded in 2015, TuSimple is a global autonomous trucking solution company headquartered in San Diego, operating self-driving trucks out of Tucson, Arizona. TuSimple is now developing a commercial-ready Level 4 (SAE) fully-autonomous driving solution for the logistics industry. TuSimple's trucks are the first and only capable of self-driving from depot-to-depot and do so every day for its customers. The company is driven by a mission to increase safety, decrease transportation costs, and reduce carbon emissions.

Nowadays, the trucking industry is currently facing a shortage of 50000 drivers (which is expected to increase to 175000 by the end of 2024) and is approaching a 100 percent turnover rate per year with an average driver age of 49 years old. According to a PwC study, autonomous trucking technologies will reduce annual operating costs for a traditional average long-haul truck by 28 percent in 2025. TuSimple is aiming to transform the 740-billion U.S. trucking industry by cutting costs, reducing carbon emissions and eradicating some of the challenges currently faced by operators.

Building the industry's first 1000-meter perception system, TuSimple soon becomes the pioneer in the industry. As is known to us, 1000 meters can provide 35 seconds of reaction time on average at highway speeds, enabling the system to make the safest and most efficient driving decisions. Even in the adverse weather conditions, the perception system is still designed to identify objects and obstacles, ensuring the safety of both cargoes, trucks, and passers-by. On the other hand, TuSimple's latest proprietary AI is now capable of long-distance highway driving and complex surface street driving, which allows fully autonomous deliveries from one depot to another.

Despite their advanced technology and an enormous sense of mission in the industry, TuSimple shares the corporate culture of honesty, realistic, exploration and innovation among their employees from bottom to top, which allows them to attract more and more elites from all expertise to join and get involved. "Here's why a little-known autonomous trucking company is beating Tesla and Waymo in the race for driverless big rigs", commented by Business Insider.


The future of trucking is now!

As a manager of TuSimple, you are going to hold a dancing party for both the Development Department and the Marketing Department. There will be  gentlemen and  ladies in total and they are going to dance in pairs. After a careful investigation, we have already known that for each person, they like to dance with either a taller person or a person with smaller height. To simplify the problem, there are no two persons of the same height and people are only allowed to dance with a person of the opposite gender. In order to reserve a proper dancing field, you must calculate the maximum possible number of pairs of people dancing at the same time.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  (), indicating the number of gentlemen and ladies.

The second line contains  integers  (,  for all ), indicating the height of each gentleman.

The third line contains  integers  (,  for all ), indicating the height of each lady.

The fourth line contains  integers  (), indicating the preference of each gentleman. If , it means gentleman  prefers to dance with a lady of smaller height. Otherwise it indicates he prefers to have a taller dancing partner.

The fifth line contains  integers  (), indicating the preference of each lady. If , it means lady  prefers to dance with a gentleman of smaller height. Otherwise it indicates she prefers to have a taller dancing partner.

It's guaranteed that the sum of  and  of all test cases will not exceed  and  for all .

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

1
3 3
1 2 5
3 4 6
1 1 0
0 0 1

Sample Output

2

Hint

In the sample test case, the 1st gentleman can dance with the 2nd lady, and the 2nd gentleman can dance with the 1st lady.


Submit    Status


Copyright @ 2001-2019, Zhejiang University ACM/ICPC Team, All rights reserved.

 题目大意:

T组数据

每组数据n个男生,m个女生

接下来两行分别是男生和女生的身高

接下来两行分别是表明对应的的男生想找一个比自己高的异性还是比自己矮的异性,0表示异性比自己矮,1表示异性比自己高

思路

这个题目不是最大匹配,时间超了

真正的思路:贪心,往死里贪

将男生女生的按照身高和选择异性的标准排序,然后男生找矮的和女生找高的的匹配,女生找d矮的和男生找高的匹配

最后的结果就是答案。

O(n)的算法

This is the codes:

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define pppp cout<<endl;
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x3f3f3f3f      //1061109567
#define LL_INF 0x3f3f3f3f3f3f3f3f //4557430888798830399
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int dr[]= {0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]= {-1, 1, 0, 0, -1, 1, -1, 1};
int read()//输入外挂
{
    int ret=0, flag=0;
    char ch;
    if((ch=getchar())=='-')
        flag=1;
    else if(ch>='0'&&ch<='9')
        ret = ch - '0';
    while((ch=getchar())>='0'&&ch<='9')
        ret=ret*10+(ch-'0');
    return flag ? -ret : ret;
}
const int maxn=100050;
struct node
{
    int heigh;
    int select;
} a[maxn],b[maxn];
bool cmp(node x,node y) //排序,现把0放在前面,1放在后面
{
    if(x.select==y.select)
        return x.heigh<y.heigh;
    else
        x.select<y.select;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m); //全部初始化为未匹配点
        for(int i=0; i<n; ++i)
            scanf("%d",&a[i].heigh);
        for(int i=0; i<m; ++i)
            scanf("%d",&b[i].heigh);

        int cnt1=0;//男生0的个数
        int cnt2=0;//女生0的个数
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i].select);
            if(!a[i].select)
                ++cnt1;
        }
        for(int i=0; i<m; ++i)
        {
            scanf("%d",&b[i].select);
            if(!b[i].select)
                ++cnt2;
        }

        sort(a,a+n,cmp);
        sort(b,b+m,cmp);


        int num=0;
        int j=cnt2;
        for(int i=0; i<cnt1; ++i) //男生高,女生矮
        {
            if(a[i].heigh>b[j].heigh)
            {
                num++;
                j++;
            }
            if(j>=m)
                break;
        }

        j=cnt1;
        for(int i=0; i<cnt2; ++i) //女生高,男生矮
        {
            if(b[i].heigh>a[j].heigh)
            {
                num++;
                j++;
            }
            if(j>=n)
                break;
        }
        printf("%d\n",num);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值