P2872 道路建设

题目描述

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (Xi, Yi) on the plane (0 ≤ Xi ≤ 1,000,000; 0 ≤ Yi ≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

Farmer John最近得到了一些新的农场,他想新修一些道路使得他的所有农场可以经过原有的或是新修的道路互达(也就是说,从任一个农场都可以经过一些首尾相连道路到达剩下的所有农场)。有些农场之间原本就有道路相连。 所有N(1 <= N <= 1,000)个农场(用1..N顺次编号)在地图上都表示为坐标为(X_i, Y_i)的点(0 <= X_i <= 1,000,000;0 <= Y_i <= 1,000,000),两个农场间道路的长度自然就是代表它们的点之间的距离。现在Farmer John也告诉了你农场间原有的M(1 <= M <= 1,000)条路分别连接了哪两个农场,他希望你计算一下,为了使得所有农场连通,他所需建造道路的最小总长是多少。
输入输出格式
输入格式:

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Two space-separated integers: Xi and Yi

* Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

    第1行: 2个用空格隔开的整数:N 和 M

    第2..N+1行: 第i+1行为2个用空格隔开的整数:X_i、Y_i

    第N+2..N+M+2行: 每行用2个以空格隔开的整数i、j描述了一条已有的道路, 这条道路连接了农场i和农场j

输出格式:

* Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

输出使所有农场连通所需建设道路的最小总长,保留2位小数,不必做 任何额外的取整操作。为了避免精度误差,计算农场间距离及答案时 请使用64位实型变量

输入输出样例
输入样例#1: 

4 1
1 1
3 1
2 3
4 3
1 4

输出样例#1: 

4.00

题目简述:给出n个点的坐标,其中一些点已经连通,现在要把所有点连通,求修路的最小长度.
所以本题只要把已有的道路边权设为零,计算没有连通的两点间距离,然后跑一边最小生成树即可。

Code:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=1005;
int n,m,fa[N],x[N],y[N],Cnt;
double ans,Tmp;
struct Node{
    int u,v;
    double w;
}Edge[N*N];
bool cmp(Node a,Node b){
    return a.w<b.w;
}
int Find(int t){
    return t==fa[t]?t:fa[t]=Find(fa[t]);
}
double l(int a,int b){
    return sqrt((double)(x[a]-x[b])*(x[a]-x[b])+(double)(y[a]-y[b])*(y[a]-y[b]));
}
void Push(int u,int v,double w){
    Edge[++Cnt].u=u;
    Edge[Cnt].v=v;
    Edge[Cnt].w=w;
}
int main(){
    int u,v;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){
        fa[i]=i;
    }
    for(int i=1;i<=n;i++){
        scanf("%d%d",&x[i],&y[i]);
        for(int j=1;j<i;j++){
            Push(i,j,l(i,j));
        }
    }
    sort(Edge+1,Edge+1+Cnt,cmp);
    for(int i=1;i<=m;i++){
        scanf("%d%d",&u,&v);
        u=Find(u);
        v=Find(v);
        fa[u]=v;
    }
    for(int i=1;i<=Cnt;i++){
        int u=Find(Edge[i].u),v=Find(Edge[i].v);
        if(u!=v){
            fa[u]=v;
            ans+=Edge[i].w;
        }
    }
    printf("%.2f\n",ans);
    return 0;
}

转载于:https://www.cnblogs.com/ukcxrtjr/p/11184625.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值