[Ubuntu] 编译安装 PHP 依赖库

编译环境

sudo apt-get -y install build-essential

xml

sudo apt-get -y install libxml2-dev

pcre

sudo apt-get -y install libpcre3-dev

jpeg

sudo apt-get -y install libjpeg62-dev

freetype

sudo apt-get -y install libfreetype6-dev

png

sudo apt-get -y install libpng12-dev libpng3 libpnglite-dev

iconv

sudo apt-get -y install libiconv-hook-dev libiconv-hook1

mycrypt

sudo apt-get -y install libmcrypt-dev libmcrypt4

mhash

sudo apt-get -y install libmhash-dev libmhash2

openssl

sudo apt-get -y install libltdl-dev libssl-dev

curl

sudo apt-get -y install libcurl4-openssl-dev

mysql

sudo apt-get -y install libmysqlclient-dev

imagick

sudo apt-get -y install libmagickcore-dev libmagickwand-dev

ubuntu 无法找到 iconv

sudo ln -s /usr/lib/libiconv_hook.so.1.0.0 /usr/lib/libiconv.so
sudo ln -s /usr/lib/libiconv_hook.so.1.0.0 /usr/lib/libiconv.so.1

安装PHP扩展

sudo apt-get -y install autoconf automake m4

 

转载于:https://www.cnblogs.com/52php/p/6937390.html

表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页