poj 2524 Ubiquitous Religions

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15693 Accepted: 7549

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
#include <iostream>
using namespace std;

const int MAXN = 50010; /*结点数目上线*/
int pa[MAXN]; /*p[x]表示x的父节点*/
int rank[MAXN]; /*rank[x]是x的高度的一个上界*/

int n;
int res;

void make_set(int x)/*创建一个单元集*/
{
pa[x] = x;
rank[x] = 0;
}

int find_set(int x) /*带路径压缩的查找*/
{
if(x != pa[x])
pa[x] = find_set(pa[x]);
return pa[x];
}

/*按秩合并x,y所在的集合*/
void union_set(int x, int y)
{
x = find_set(x);
y = find_set(y);
if(x==y)
return;
if(rank[x] > rank[y])/*让rank比较高的作为父结点*/
pa[y] = x;
else
{
pa[x] = y;
if(rank[x] == rank[y])
rank[y]++;
}
res--;
}

int main()
{
int m;
int cases=0;
while(1)
{
cin>>n;
cin>>m;
int i,j;
int k;
if(n==0&&m==0)
break;
cases++;
for(k=1;k<=n;k++)
make_set(k);
res=n;
for(k=0;k<m;k++)
{
cin>>i>>j;
union_set(i,j);
}
cout<<"Case "<<cases<<": "<<res<<endl;
}
return 0;
}

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258577.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值