题目66:畅通工程

http://ac.jobdu.com/problem.php?cid=1040&pid=65

题目描述:

    某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

输入:

    测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
    注意:两个城市之间可以有多条道路相通,也就是说
    3 3
    1 2
    1 2
    2 1
    这种输入也是合法的
    当N为0时,输入结束,该用例不被处理。

输出:

    对每个测试用例,在1行里输出最少还需要建设的道路数目。

样例输入:
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
样例输出:
1
0
2
998
// 题目66:畅通工程.cpp: 主项目文件。

#include "stdafx.h"
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
using namespace std;

const int N=1003;
int tree[N];
int n;
int cnt;

void Init()
{
	for(int i=0;i<=n;i++)
		tree[i]=-1;
}

int findRootSet(int x)
{
	if(tree[x]==-1)
		return x;
	else
	{
		int ret=findRootSet(tree[x]);
		tree[x]=ret;
		return ret;
	}
}

void unionSet(int x,int y)
{
	int root1=findRootSet(x);
	int root2=findRootSet(y);
	if(root1!=root2)
	{
		tree[root1]=root2;
		cnt++;
	}
}

int main()
{
    //freopen("F:\\test.txt","r",stdin);
    //freopen("F:\\output.txt","w",stdout);
	int m;
	while(cin>>n&&n!=0)
	{
		cnt=0;
		Init();
		cin>>m;
		while(m--)
		{
			int from,to;
			cin>>from>>to;
			unionSet(from,to);
		}
		cout<<n-1-cnt<<endl;
	}
    return 0;
}


转载于:https://www.cnblogs.com/cjweffort/archive/2013/03/10/3374868.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值