hdu 1250

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5445    Accepted Submission(s): 1820


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

 

Input
Each line will contain an integers. Process to end of file.
 

 

Output
For each case, output the result in a line.
 

 

Sample Input
100
 

 

Sample Output
4203968145672990846840663646
Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
#include<stdio.h>
#include<string.h> 
int a[8000][300];
int main() 

    int i,j,n,num[8000];
    memset(a,0,sizeof(a));
    memset(num,0,sizeof(num));
    a[1][0]=a[2][0]=a[3][0]=a[4][0]=1; 
    num[1]=num[2]=num[3]=num[4]=1; 
    for(i=5;i<8000;i++)  //打表
    { 
        for(j=0;j<num[i-1];j++)  //num[]用来储存a[i][j]的位数
        { 
            a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]; 
            a[i][j+1]+=a[i][j]/100000000; 
            a[i][j]%=100000000; 
        } 
        num[i]=num[i-1]; 
        if(a[i][num[i]]!=0)
            num[i]++; 
    } 
    while(~scanf("%d",&n)) 
    { 
        if(n==0) 
        {
            printf("0\n");
            continue;
        } 
     printf("%d",a[n][num[n]-1]); 
        for(i=num[n]-2;i>=0;i--)
            printf("%08d",a[n][i]);  //位数不足8位的,在前边补充0
        printf("\n"); 
    } 
    return 0; 
}

转载于:https://www.cnblogs.com/lxm940130740/p/3268147.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值