HDU——1393Weird Clock(水题,注意题意)

Weird Clock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3109    Accepted Submission(s): 1137

Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won't move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin's type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.
 

 

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.
 

 

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output "Impossible".
 

 

Sample Input
30 1 0 0
 

 

Sample Output
1
题意:一个0~59分的时钟,只有分针,给你一个初始时刻s和单次转动次数d。叫你求出多少次以后可以转到0刻度。刚开始我是想着转n个d次,则有(s+n*d*s)%60==0这样一条公式,但是怎么提交都是错,后来看讨论区说是题意问题,再看看题目也没发现啥。最后看了题解,发现每转一次d将把当前的刻度视为单位转动刻度,而非一直是最开始的刻度,比如25 5,第一次到达(25+5*25)%60=30分,第二次则会到达(30+5*30)%60=0刻度,因此第二次就到了。若是刚开始错误的公式(s+n*d*s)%60==0,则n会等于7
代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main(void)
{
	int s,d,n;
	bool ok;
	while (~scanf("%d%d",&s,&d)&&(s||d))
	{
		ok=true;
		n=0;//计数器要初始化为0,对应一开始就到达0刻度的情况 
		while (s%60!=0)
		{
			s=(s+s*d)%60;	
			n++;		
			if(n>=61)
			{
				ok=false;//标记变量 
				break;
			}
		}
		if(ok)
			cout<<n<<endl;
		else
			cout<<"Impossible"<<endl;				
	}	
	return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/5356434.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值