HDU 2069

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7505    Accepted Submission(s): 2489


Problem Description

 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

 

Input

 

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

 

Output

 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

 

Sample Input
11
26
 

 

Sample Output
4
13
 
看完题目就本能性地用了母函数,敲好试了下数据 对的 很开心submit了 结果WA 再看一遍题目 猛然间惊醒……
Your program should be able to handle up to 100 coins.
然后就不知道怎么处理了……
 
 
后来百度了 发现有直接暴力过的…… 无语
 
View Code
#include<stdio.h>
#include<string.h>

int main()
{
    int n,i,j,k,m,cent,a[6]={1,5,10,25,50},c[252];
     memset(c,0,sizeof(c));
    for(i=0;i<101&&a[0]<251;i++)
        for(j=0;i+j<101&&a[0]*i+a[1]*j<251;j++)
            for(k=0;i+j+k<101&&a[0]*i+a[1]*j+a[2]*k<251;k++)
                for(m=0;i+j+k+m<101&&a[0]*i+a[1]*j+a[2]*k+a[3]*m<251;m++)
                    for(n=0;i+j+k+m+n<101&&a[0]*i+a[1]*j+a[2]*k+a[3]*m+a[4]*n<251;n++)
                        c[a[0]*i+a[1]*j+a[2]*k+a[3]*m+a[4]*n]+=1;
              
    while(scanf("%d",&cent)!=EOF)
    {
        printf("%d\n",c[cent]);
    }
return 0;
}

 

转载于:https://www.cnblogs.com/Action-/archive/2012/04/22/2465219.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值