Friendship

Friendship
Time Limit: 2000MS Memory Limit: 20000K
Total Submissions: 9824 Accepted: 2720

Description
In modern society, each person has his own friends. Since all the people are very busy, they communicate with each other only by phone. You can assume that people A can keep in touch with people B, only if
1. A knows B’s phone number, or
2. A knows people C’s phone number and C can keep in touch with B.
It’s assured that if people A knows people B’s number, B will also know A’s number.

Sometimes, someone may meet something bad which makes him lose touch with all the others. For example, he may lose his phone number book and change his phone number at the same time.

In this problem, you will know the relations between every two among N people. To make it easy, we number these N people by 1,2,…,N. Given two special people with the number S and T, when some people meet bad things, S may lose touch with T. Your job is to compute the minimal number of people that can make this situation happen. It is supposed that bad thing will never happen on S or T.

Input
The first line of the input contains three integers N (2<=N<=200), S and T ( 1 <= S, T <= N , and S is not equal to T).Each of the following N lines contains N integers. If i knows j’s number, then the j-th number in the (i+1)-th line will be 1, otherwise the number will be 0.

You can assume that the number of 1s will not exceed 5000 in the input.

Output
If there is no way to make A lose touch with B, print “NO ANSWER!” in a single line. Otherwise, the first line contains a single number t, which is the minimal number you have got, and if t is not zero, the second line is needed, which contains t integers in ascending order that indicate the number of people who meet bad things. The integers are separated by a single space.

If there is more than one solution, we give every solution a score, and output the solution with the minimal score. We can compute the score of a solution in the following way: assume a solution is A1, A2, …, At (1 <= A1 < A2 <…< At <=N ), the score will be (A1-1)*N^t+(A2-1)*N^(t-1)+…+(At-1)*N. The input will assure that there won’t be two solutions with the minimal score.

Sample Input

3 1 3
1 1 0
1 1 1
0 1 1

Sample Output

1
2

Source
POJ Monthly
题意:给不同的人之间的联系,问至少有多少人遇到糟糕的事情会使S,T之间断开联系;
这个题需要拆点,将点拆成(i,i+N),之间的容量为一,遇到糟糕的事情就是自己与自己失去联系,通过最大流可以判断最小割,然后枚举点找字典序最最小的.

#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
const int INF =0x3f3f3f3f;
const double eps =1e-8;
const int Max =3000;
struct node
{
    int cap;
    int flow;
} Map[500][500];
int Set[500];
int Du[555];
bool vis[555];
int S,T,N;
int  s,t;
void AddEdge(int u,int v,int w)
{
    Map[u][v].cap = w;
}
bool BFS()
{
    memset(Du,0,sizeof(Du));
    memset(vis,false,sizeof(vis));
    queue<int>Q;
    Du[s]=1;
    vis[s]=true;
    Q.push(s);
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        for(int i=0; i<=t; i++)
        {
            if(!vis[i]&&Map[u][i].cap>Map[u][i].flow)
            {
                vis[i]=true;
                Du[i]=Du[u]+1;
                Q.push(i);
            }
        }
    }
    return vis[t];
}
int DFS(int star,int num)
{
    if(star==t)
    {
        return num;
    }
    int a=0;
    int ant;
    for(int i=0; i<=t; i++)
    {
        if(Du[i]==Du[star]+1&&Map[star][i].cap>Map[star][i].flow)
        {
            if(ant=DFS(i,min(num,Map[star][i].cap-Map[star][i].flow)))
            {
                Map[star][i].flow+=ant;
                Map[i][star].flow-=ant;
                num-=ant;
                a+=ant;
                if(num==0)
                {
                    break;
                }
            }
        }
    }
    return a;
}
void Dinic()
{
    int ans=0;
    while(BFS())
    {
        ans+=DFS(0,INF);
    }
    printf("%d\n",ans);
    if(!ans)
    {
        return ;
    }
    int cut=0;
    int tmp=ans;
    for(int i=1; i<=N&&tmp; i++)
    {
        if(i==S||i==T)
        {
            continue;
        }
        if(Map[i][i+N].flow==0)
        {
            continue;
        }
        Map[i][i+N].cap=0;
        for(int a=1; a<=t; a++)
        {
            for(int b=1; b<=t; b++)
            {
                Map[a][b].flow=0;
            }
        }
        ans=0;
        while(BFS())
        {
            ans+=DFS(0,INF);
        }
        if(ans!=tmp)
        {
            Set[cut++]=i;
            tmp=ans;
        }
        else
        {
            Map[i][i+N].cap=1;
        }
    }
    for(int i=0; i<cut; i++)
    {
        if(i)
        {
            printf(" ");
        }
        printf("%d",Set[i]);
    }
    printf("\n");
}
int main()
{
    int data;
    while(~scanf("%d %d %d",&N,&S,&T))
    {
        memset(Map,0,sizeof(Map));
        s=0;
        t=N*2+1;
        AddEdge(s,S,INF);
        AddEdge(T+N,t,INF);
        for(int i=1; i<=N; i++)
        {
            AddEdge(i,i+N,1);
            for(int j=1; j<=N; j++)
            {
                scanf("%d",&data);
                if(data)
                {
                    AddEdge(i+N,j,INF);
                }
            }
        }
        AddEdge(S,S+N,INF);
        AddEdge(T,T+N,INF);
        if(!Map[S+N][T].cap)
        {

            Dinic();
        }
        else
        {
            printf("NO ANSWER!\n");
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5256012.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值