ZOJ1428(Magazine Delivery)

Magazine Delivery

Time Limit: 1 Second      Memory Limit: 32768 KB

The TTT Taxi Service in Tehran is required to deliver some magazines to N locations in Tehran. The locations are labeled L1 to LN. TTT assigns 3 cars for this service. At time 0, all the 3 cars and magazines are located at L1. There are plenty of magazines available in L1 and the cars can take as many as they want. Copies of the magazine should be delivered to all locations, observing the following rules:

1. For all i = 2 .. N, magazines should be delivered at Li only after magazines are delivered at Li-1.

2. At any time, only one of the three cars is driving, and the other two are resting in other locations.

The time to go from Li to Lj (or reverse) by any car is a positive integer denoted by D[i , j].

The goal is to organize the delivery schedule for the cars such that the time by which magazines are delivered to all N locations is minimum.

Write a program to compute the minimum delivery time.


Input

The input file contains M instances of this problem (1 <= M <= 10). The first line of the input file is M. The descriptions of the input data follows one after the other. Each instance starts with N in a single line (N <= 30). Each line i of the following N-1 lines contains D[i , j], for all i=1..N-1, and j=i+1..N.


Output

The output file contains M lines, each corresponding the solution to one of the input data. In each line, the minimum time it takes to deliver the magazines to all N locations is written.


Sample Input

1
5
10 20 3 4
5 10 20
8 18
19


Sample Output

22

//Accepted  1428 C++ 0 316 Xredman 
#include <iostream>
using namespace std;

const int N = 32;

int n;
int graph[N][N];
int dp[N][N][N];

int dfs(int a, int b, int c)
ExpandedBlockStart.gifContractedBlock.gif
{//c始终为三辆车行的最远的一辆

ExpandedSubBlockStart.gifContractedSubBlock.gif    
/**//此为底//
    if(c == n)
        
return 0;
ExpandedSubBlockStart.gifContractedSubBlock.gif    
/**/以搜索过////
    if(dp[a][b][c] > 0)
        
return dp[a][b][c];

    
//c车行
    if(dp[a][b][c + 1== 0) dp[a][b][c + 1= dfs(a, b, c + 1);
    
//b车行
    if(dp[a][c][c + 1== 0) dp[a][c][c + 1= dfs(a, c, c + 1);
    
//a车行
    if(dp[c][b][c + 1== 0) dp[c][b][c + 1= dfs(c , b, c + 1);
    
    dp[a][b][c] 
= min(dp[a][b][c + 1+ graph[c][c + 1], dp[a][c][c + 1+ graph[b][c + 1]);
    dp[a][b][c] 
= min(dp[a][b][c], dp[c][b][c + 1+ graph[a][c + 1]);
    
return dp[a][b][c];
}


int main()
ExpandedBlockStart.gifContractedBlock.gif
{
    
int T;
    
int i, j, k;
    scanf(
"%d"&T);
    
while(T-- && scanf("%d"&n))
ExpandedSubBlockStart.gifContractedSubBlock.gif    
{
        
for(i = 1; i <= n; i++)
ExpandedSubBlockStart.gifContractedSubBlock.gif        
{
            graph[i][i] 
= 0;
            
for(j = i + 1; j <= n; j++)
ExpandedSubBlockStart.gifContractedSubBlock.gif            
{
                scanf(
"%d"&graph[i][j]);
                graph[j][i] 
= graph[i][j];
            }

        }


        
for(i = 1; i <= n; i++)
            
for(j = 1; j <= n; j++)
                
for(k = 1; k <= n; k++)
                    dp[i][j][k] 
= 0;
        dfs(
111);
        cout
<<dp[1][1][1]<<endl;
    }

    
return 0;
}

ExpandedBlockStart.gifContractedBlock.gif
/**//*
1
5
10 20 3 4
5 10 20
8 18
19
///
0  10  20  3  4
10  0  5  10  20
20  5  0  8  18
3  10  8  0  19
4  20  18  19  0
*/

转载于:https://www.cnblogs.com/Xredman/archive/2009/04/21/1440744.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值