hdu-5752 Sqrt Bo(水题)

题目链接:

Sqrt Bo

Time Limit: 2000/1000 MS (Java/Others)   

 Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Let's define the function  f(n)=n−−√.

Bo wanted to know the minimum number y which satisfies fy(n)=1.

note:f1(n)=f(n),fy(n)=f(fy1(n))

It is a pity that Bo can only use 1 unit of time to calculate this function each time.

And Bo is impatient, he cannot stand waiting for longer than 5 units of time.

So Bo wants to know if he can solve this problem in 5 units of time.
 

 

Input
This problem has multi test cases(no more than  120).

Each test case contains a non-negative integer n(n<10100).
 

 

Output
For each test case print a integer - the answer  y or a string "TAT" - Bo can't solve this problem.
 

 

Sample Input
233
233333333333333333333333333333333333333333333333333333333
 

 

Sample Output
3
TAT
 
题意:
 
问这个数开几次平方得到1;如果超过五的话就TAT;
 
思路:
 
开五次方还没变成1的数大于十位了吧;
然后把这个数转成long long 看开几次平方变成1;
 
AC代码:
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>
#include <stack>

using namespace std;

#define For(i,j,n) for(int i=j;i<=n;i++)
#define mst(ss,b) memset(ss,b,sizeof(ss));

typedef  unsigned long long LL;

template<class T> void read(T&num) {
    char CH; bool F=false;
    for(CH=getchar();CH<'0'||CH>'9';F= CH=='-',CH=getchar());
    for(num=0;CH>='0'&&CH<='9';num=num*10+CH-'0',CH=getchar());
    F && (num=-num);
}
int stk[70], tp;
template<class T> inline void print(T p) {
    if(!p) { puts("0"); return; }
    while(p) stk[++ tp] = p%10, p/=10;
    while(tp) putchar(stk[tp--] + '0');
    putchar('\n');
}

const LL mod=1e9+7;
const double PI=acos(-1.0);
const int inf=1e9;
const int N=1e7+10;
const int maxn=1000+10;
const double eps=1e-8;


char s[110];

int main()
{
        while(scanf("%s",s)!=EOF)
        {
            int len=strlen(s);
            if(len>10)cout<<"TAT"<<"\n";
            else
            {
                LL x=0;
                for(int i=0;i<len;i++)
                {
                    x=x*10;
                    x=x+s[i]-'0';
                }
                if(x==0){cout<<"TAT\n";continue;}
                int ans=0;
                while(ans<=10)
                {
                    x=floor(sqrt(x));
                    ans++;
                    if(x==1)break;
                }
                if(ans>5)cout<<"TAT"<<"\n";
                else cout<<ans<<"\n";
            }
        }
        return 0;
}

  

转载于:https://www.cnblogs.com/zhangchengc919/p/5708995.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值