Bomb(要49)--数位dp

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 25866    Accepted Submission(s): 9810


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

 

Output
For each test case, output an integer indicating the final points of the power.
 

 

Sample Input
3
1
50
500
 

 

Sample Output
0
1
15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

 

#include<iostream>
#include<string.h>
#define ll long long
using namespace std;
ll shu[20], dp[20][2];
ll dfs(ll len, bool if4, bool shangxian)
{
    if (len == 0)
        return 1;
    if (!shangxian&&dp[len][if4])
        return dp[len][if4];
    ll mx, cnt = 0;//cnt记录的是区间内不含49的个数
    mx = (shangxian ? shu[len] : 9);
    for (ll i = 0; i <= mx; i++)
    {
        if (if4&&i == 9)//如果shu[len]==4&&上一个状态是9
            continue;
        cnt = cnt + dfs(len - 1, i == 4, shangxian&&i == mx);
    }
    return shangxian ? cnt : dp[len][if4] = cnt;
}
ll solve(ll n)
{
    memset(shu, 0,sizeof(shu));
    ll k = 0;
    while (n)//将n的每一位拆解出来逆序存在shu[i]中。eg:109,shu[0]=9,shu[1]=0,shu[2]=1;
    {
        shu[++k] = n % 10;//注意这里是++k
        n = n / 10;
    }
    return dfs(k, false, true);
}
int main()
{
    ll t;
    scanf("%lld", &t);
    while (t--)
    {
        ll n;
        scanf("%lld", &n);//这里计算的区间是[0,n],题目要计算的是[1,n];
        printf("%lld\n", n-(solve(n)-1));
        //如果是计算区间[a,b];printf(solve(b)-solve(a-1));

    }
    return 0;

}

 

转载于:https://www.cnblogs.com/-citywall123/p/10745755.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值