hdu3555(入门数位DP)

                                                   Bomb

                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
                                  Total Submission(s): 22434    Accepted Submission(s): 8435


 

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3 1 50 500

Sample Output

0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

Author

fatboy_cw@WHU

 Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

题意:给出一个数,让你找出不大于这个数的所有数中,包含49这个数的数字。

一道简单的数位DP题,可以用来理解数位DP。

首先用init()来找出最多用n位数(n位以及不足n位的数)有多少含有49的数,

  • dp[i[[j]用于存储符合条件的数的个数 i代表目前处理的数长度为i 这里dp[i][j]处理的数可包含前导零

  • dp[i][0]代表长度为i的数中不含49数的数量 dp[i][1]代表长度为i的数中不含49但是最高位为9的数的数量

  • dp[i][2]代表长度为i的数中包含49的数的数量

然后开始找小于给的数字有多少包含49的。from len to 1,到len位时,len位之前的全是所给的数字的最大所能放置的数字(即为a[i]),len位小于所给数字(即为a[i])

#include<bits/stdc++.h>
using namespace std;

long long dp[65][3];
int a[65];

void init()
{
    dp[0][0]=1;
    dp[0][1]=dp[0][2]=0;
    for(int i=1;i<64;i++)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
        dp[i][1]=dp[i-1][0];
        dp[i][2]=dp[i-1][1]+dp[i-1][2]*10;
    }
    return;

}

long long compute(int len)
{
    long long ans=0;
    int flag=0;
    for(int i=len;i>0;i--)
    {
        ans+=dp[i-1][2]*a[i];                ///第一次计算i=len时,已经囊括了所有不足len位的情况
        if(flag) ans+=dp[i-1][0]*a[i];       ///在之后的计算中,前面所有位都已变成了给定的数位上的最大值
        if(!flag&&a[i]>4) ans+=dp[i-1][1];   ///(这里一定是大于4,大于3的话可能下一位不到9从而多算了)
        if(a[i+1]==4&&a[i]==9) flag=1;       ///所以才会出现判断相邻4、9然后令flag=1的情况

    }
    return ans;
}

int main()
{
    long long t,temp;
    int num;
    init();
    scanf("%d",&num);
    while(num--)
    {
        scanf("%I64d",&t);
        int len=0,i=0;
        temp=t+1;              //deal with t+1
        while(temp)
        {
            a[++i]=temp%10;
            temp/=10;
            len++;
        }
        a[len+1]=0;              //防止后续检测i+1时越界
        printf("%I64d\n",compute(len));
    }
    return 0;
}

 

  • 4
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值