HDU 3407.Zjnu Stadium 加权并查集

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3726    Accepted Submission(s): 1415


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

 

Input
There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

 

Output
For every case: 
Output R, represents the number of incorrect request.
 

 

Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
 

 

Sample Output
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)
 

 

Source
题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=3047
题意:n个点,m个关系。每个关系有3个整数a,b,x表示为a到b的距离为x。问m个关系中有几个不合理的。
思路:并查集,在压缩路径的时候顺便处理一下距离dist[x]+=dist[pa[x]]。关系合并时距离关系为:dist[fb]=dist[a]+x-dist[b](fb为b的祖先;dist[a],diat[b]分别表示a,b到祖先的距离)。
 
代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<set>
using namespace std;
#define PI acos(-1.0)
typedef long long ll;
typedef pair<int,int> P;
const int maxn=1e5+100,maxm=1e5+100,inf=0x3f3f3f3f,mod=1e9+7;
const ll INF=1e13+7;
int pa[maxn];
int dist[maxn];
void init(int n)
{
    for(int i=1; i<=n; i++)
        pa[i]=i,dist[i]=0;
}
int findset(int x)
{
    if(pa[x]==x) return x;
    int fax=pa[x];
    pa[x]=findset(pa[x]);
    dist[x]+=dist[fax];
    return pa[x];
}
void unit(int x,int y,int w)
{
    int fx=findset(x),fy=findset(y);
    pa[fx]=fy;
    dist[fx]=dist[y]+w-dist[x];
}
bool same(int x,int y,int w)
{
    if(findset(x)!=findset(y)) return false;
    else if(dist[findset(x)]==dist[y]+w-dist[x]) return false;
    else return true;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int ans=0;
        init(n);
        for(int i=1; i<=m; i++)
        {
            int a,b,x;
            scanf("%d%d%d",&a,&b,&x);
            if(same(a,b,x)) ans++;
            else unit(a,b,x);
        }
        cout<<ans<<endl;
    }
    return 0;
}
加权并查集

 

 

转载于:https://www.cnblogs.com/GeekZRF/p/7113263.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值