hdu3555 Bomb (数位dp入门题)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 19698    Accepted Submission(s): 7311

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3 1 50 500

Sample Output

0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

代码(dfs解法):

#include<iostream>
#include<cstring>
#define LL long long
using namespace std;

LL bit[25], dp[25][2];

LL dfs(int pos, int is4, int lim)//pos当前位, is4上一位是否为4, lim上一位是否取到最大值
{
    if(pos<0) return 1;
    if(!lim && dp[pos][is4]!=-1) return dp[pos][is4];
    int las=lim?bit[pos]:9;//若上以一位没有取最大值位则可以0~9循环
    LL res=0;
    for(int i=0; i<=las; ++i)
        if(!(is4 && i==9))//搜索不含49的,结果取反
            res+=dfs(pos-1, i==4, lim&&i==las);
    if(!lim) dp[pos][is4]=res;
    return res;
}

int main()
{
    int T;
    memset(dp, -1, sizeof(dp));
    cin>>T;
    while(T--)
    {
        LL n;
        cin>>n;
        LL len=0, m=n;
        while(n)
        {
            bit[len++]=n%10;
            n/=10;
        }
        LL ans=m-dfs(len-1, 0, 1)+1;//结果取反, 且搜索过程中会包含0, 故+1
        cout<<ans<<endl;
    }
    return 0;
}

 代码(传统dp):

#include<iostream>
#include<cstring>
#include<cstdio>
#define LL long long
using namespace std;

LL num[25], dp[25][3];

int main()
{
    int T;
    memset(dp, 0, sizeof(dp));
    dp[0][0]=1;
    for(int i=1; i<21; ++i)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];//dp[i][0]表示i位数不包含49且最高位不是9的数目
        dp[i][1]=dp[i-1][0];//dp[i][1]表示i位数不包含49且最高位是9的数目
dp[i][
2]=dp[i-1][2]*10+dp[i-1][1];//dp[i][2]表示i位数包含49的数目 } cin>>T; while(T--) { LL n; cin>>n; int len=0; memset(num, 0, sizeof(num)); while(n) { num[++len]=n%10; n/=10; } int las=0; bool flag=false; LL ans=0; for(int i=len; i>=1; --i) { ans+=(dp[i-1][2]*num[i]);//若n=789, 则i=3时此处计算700以内的结果 if(flag) ans+=dp[i-1][0]*num[i];//若之前已包含49 if(!flag && num[i]>4) ans+=dp[i-1][1];//若之前未包含49 if(las==4 && num[i]==9) flag=true; las=num[i]; } if(flag) ans++; cout<<ans<<endl; } return 0; }

 

转载于:https://www.cnblogs.com/xiepingfu/p/7439983.html

基于STM32设计的数字示波器全套资料(原理图、PCB图、源代码) 硬件平台: 主控器:STM32F103ZET6 64K RAM 512K ROM 屏幕器:SSD1963 分辨率:480*272 16位色 触摸屏:TSC2046 模拟电路: OP-TL084 OP-U741 SW-CD4051 CMP-LM311 PWR-LM7805 -LM7905 -MC34063 -AMS1117-3.3 DRT-ULN2003 6.继电器:信号继电器 7.电源:DC +12V 软件平台: 开发环境:RealView MDK-ARM uVision4.10 C编译器:ARMCC ASM编译器:ARMASM 连机器:ARMLINK 实时内核:UC/OS-II 2.9实时操作系统 GUI内核:uC/GUI 3.9图形用户接口 底层驱动:各个外设驱动程序 数字示波器功能: 波形发生器:使用STM32一路DA实现正弦,三角波,方波,白噪声输出。 任意一种波形幅值在0-3.3V任意可调、频率在一定范围任意可调、方波占空比可调。调节选项可以通过触摸屏完成设置。 SD卡存储: SD卡波形存储输出,能够对当前屏幕截屏,以JPG格式存储在SD卡上。能够存储1S内的波形数据,可以随时调用查看。 数据传输:用C#编写上位机,通过串口完成对下位机的控制。(1)实现STOP/RUN功能(2)输出波形电压、时间参数(3)控制截屏(4)控制波形发生器(5)控制完成FFT(6)波形的存储和显示 图形接口: UCGUI 水平扫速: 250 ns*、500ns、1μs、5 μs、10μs、50μs、500 μs、5ms 、50ms 垂直电压灵敏度:10mV/div, 20mV/div, 50mV/div, 0.1V/div, 0,2V/div, 0.5V/div, 1V/div,2V/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值