【HDU 3555】 Bomb 数位dp

41 篇文章 0 订阅
27 篇文章 0 订阅

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

题意:找到【1,N】内数位里包含“49”子串的数的个数

思路(数位dp):

典型的数位dp题,我用dp[pos][sta][flag]来记录pos位置下,前面有无4(sta),以及之前有没有凑到过“49”(flag),然后枚举每个数位的各个数字即可,如果sta为真,就要对当前的‘9’分类讨论,遇到‘9’就flag置为真,然后往下继续搜索,到底了就看看flag是否为真,判断有没有凑到49.

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long ll;
ll dp[100][2][2];
ll a[100];

ll dfs(ll pos, bool sta, bool flag, bool limit )
{
    if(pos==-1)  return flag;
    if(!limit&&dp[pos][sta][flag]!=-1) return dp[pos][sta][flag];
    ll up = limit?a[pos]:9;
    ll ans = 0;
    for(ll i=0;i<=up;i++)
    {
          if(sta&&i==9) ans += dfs(pos-1,i==4, true, limit&&i==a[pos]);
          else  ans += dfs(pos-1,i==4,flag, limit&&i==a[pos]);
    }
    if(!limit) dp[pos][sta][flag] = ans;
    return ans;
}

ll solve(ll x)
{
    ll pos = 0;
    while(x)
    {
        a[pos++] = x%10;
        x /= 10;
    }
    return dfs(pos-1,false, false, true);
}

int main()
{
    memset(dp,-1,sizeof(dp));
    int kase;
    cin>>kase;
    while(kase--)
    {
        ll x;
        cin>>x;
        cout<<solve(x)<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值