POJ3254 状压dp

                                                                                                Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
   

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

 

题意:给你n*m的图,1代表可以放东西,0代表不可放东西,问你放置的东西之间不相邻的方案数

题解:状压dp;dp[i][j]  代表第i行状态为j的方案数,

最终答案就是 sigma(dp[n][i]) i=(1.....k)

///1085422276
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<cmath>
#include<map>
#include<bitset>
#include<set>
#include<vector>
using namespace std ;
typedef long long ll;
#define mem(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,127,sizeof(a));
#define TS printf("111111\n");
#define FOR(i,a,b) for( int i=a;i<=b;i++)
#define FORJ(i,a,b) for(int i=a;i>=b;i--)
#define READ(a,b) scanf("%d%d",&a,&b)
#define g 9.8
#define mod 100000000
#define eps 0.0000001
inline ll read()
{
    ll x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}
//****************************************

int k=0,a[16],n,m,s[5000];
ll dp[16][1<<16];
void init()
{
    FOR(i,0,1<<13)
    {
        if((i&i<<1)==0)s[++k]=i;
    }
}
int main()
{
    init();
    //cout<<k<<endl;
    while(READ(n,m)!=EOF)
    {
        mem(dp);  mem(a);
        FOR(i,1,n)
            FOR(j,1,m)
            {
                int x=read();
                if(x==1)a[i]=(a[i]|(1<<(j-1)));
            }
dp[0][0]=1;
        FOR(i,1,n)
        {
            FOR(j,1,k)
            {
                if((s[j]|a[i])!=a[i])continue;
                FOR(h,1,k)
                {
                    if((s[j]&s[h])==0)
                    dp[i][s[j]]=(dp[i-1][s[h]]+dp[i][s[j]])%mod;
                }
            }
        }
       ll ans=0;
        FOR(i,1,k)
        {
            ans+=dp[n][s[i]]%mod;
        }
        cout<<ans<<endl;
    }
    return 0;
}
代码

 

 

转载于:https://www.cnblogs.com/zxhl/p/4789909.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值