URAL 1998 The old Padawan 二分

The old Padawan

题目连接:

http://acm.timus.ru/problem.aspx?space=1&num=1998

Description

Yoda: Use the Force. Yes. Now, the stone. Feel it. Concentrate!
Luke Skywalker is having exhausting practice at a God-forsaken planet Dagoba. One of his main difficulties is navigating cumbersome objects using the Power. Luke’s task is to hold several stones in the air simultaneously. It takes complete concentration and attentiveness but the fellow keeps getting distracted.
Luke chose a certain order of stones and he lifts them, one by one, strictly following the order. Each second Luke raises a stone in the air. However, if he gets distracted during this second, he cannot lift the stone. Moreover, he drops some stones he had picked before. The stones fall in the order that is reverse to the order they were raised. They fall until the total weight of the fallen stones exceeds k kilograms or there are no more stones to fall down.
The task is considered complete at the moment when Luke gets all of the stones in the air. Luke is good at divination and he can foresee all moments he will get distracted at. Now he wants to understand how much time he is going to need to complete the exercise and move on.

Input

The first line contains three integers: n is the total number of stones, m is the number of moments when Luke gets distracted and k (1 ≤ n, m ≤ 10 5, 1 ≤ k ≤ 10 9). Next n lines contain the stones’ weights wi (in kilograms) in the order Luke is going to raise them (1 ≤ wi ≤ 10 4). Next m lines contain moments ti, when Luke gets distracted by some events (1 ≤ ti ≤ 10 9, ti < ti+1).

Output

Print a single integer — the number of seconds young Skywalker needs to complete the exercise.

Sample Input

5 1 4
1
2
3
4
5
4

Sample Output

8

Hint

题意

这个人每秒钟会捡起来一个物品

这个人会在某些时间发呆,如果发呆的话,他会一直丢下物品,直到丢完或者丢下价值和超过k的物品

丢下去的顺序是捡起来顺序的倒叙

问你最少多少秒,可以把所有东西都捡起来

题解:

对于发呆这个东西,直接二分就好了,二分一直丢到哪儿

代码

#include<bits/stdc++.h>
using namespace std;
const long long inf = 1LL<<50;
const int maxn = 1e5+7;
long long sum[maxn],t[maxn],a[maxn],k;
int n,m;
int main()
{
    scanf("%d%d%lld",&n,&m,&k);
    for(int i=1;i<=n;i++)
        scanf("%lld",&a[i]);
    for(int i=n;i>=1;i--)
        sum[i]=sum[i+1]+a[i];
    for(int i=1;i<=m;i++)
        scanf("%lld",&t[i]);
    t[m+1] = inf;
    sum[0] = inf;
    int now = 0;
    long long ans = 0;
    int j = 1;
    while(1)
    {
        if(j==m+1)
        {
            ans = ans + n - now;
            break;
        }
        if(t[j]>ans+n-now)
        {
            ans = ans + n - now;
            break;
        }
        now = now + (t[j]-t[j-1]) - 1;
        int l = 0,r = now,Ans = 1;
        while(l<=r)
        {
            int mid = (l+r)/2;
            if(sum[mid]-sum[now+1]>k)Ans=mid,l=mid+1;
            else r=mid-1;
        }
        now = Ans - 1;
        now = max(now,0);
        ans = t[j];
        j++;
    }
    cout<<ans<<endl;
}

转载于:https://www.cnblogs.com/qscqesze/p/5370323.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值