HDU 4004 The Frog's Games(基本算法-贪心,搜索-二分)

The Frog's Games

Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
 
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
 
  
4 11
 

Source
 

Recommend
lcy
 

题目大意:

长为L的河流,中间有n个石头,告诉你石头的位置,青蛙的跳跃能力至少为多少中途跳m次能跳过去


解题思路:

二分+贪心的题目,因为青蛙的跳跃能力越强需要的次数就越少,因此青蛙的跳跃能力有单调性,所以二分枚举青蛙的跳跃能力,在判断这个能力下是否能够跳过去,这个用贪心解决,每次在这个能力下尽可能跳到远的石头上,最后看m次是否跳到了对岸。


解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int L,n,m;
vector <int> v;

void input(){
    int x;
    v.clear();
    v.push_back(0);
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        v.push_back(x);
    }
    v.push_back(L);
    sort(v.begin(),v.end());
}

bool canJump(int dis){
    int s=0,l=0,pos=0,vsize=v.size();
    for(int i=0;i<m;i++){
        while( l<vsize && v[l]<=s+dis){
            pos=v[l];
            l++;
        }
        s=pos;
    }
    if(s>=L) return true;
    else return false;
}

void solve(){
    int l=0,r=L;
    while(l<r){
        int mid=(l+r)/2;
        if(canJump(mid)) r=mid;
        else l=mid+1;
    }
    printf("%d\n",r);
}

int main(){
    while(scanf("%d%d%d",&L,&n,&m)!=EOF){
        input();
        solve();
    }
    return 0;
}





转载于:https://www.cnblogs.com/toyking/p/3893152.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值