HDOJ 4004 The Frog's Games

The Frog's Games
Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output

For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input

        
        
6 1 2 2 25 3 3 11 2 18
 

Sample Output

        
        
4 11 
此题为最大距离最小化,用二分;求出满足要求的值中最小的那个;
代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int d[500010]; 
int L,n,m;
bool judge(int mid)
{
	int cnt=0;//记录每次情况下跳的次数 
	int last=0;//记录上次跳的位置; 
	for(int i=1;i<=n+1;)
	{
		if(d[i]<=last+mid)
		{
			i++;//继续往后走,直到找到距离能跳的位置最近的左边的石头 ; 
		}
		else
		{
			if(last==d[i-1])//假如每次都在同一个石头,说明跳不过去; 
			   return false;
			last=d[i-1];
			cnt++;
		}
	}
	cnt++;
	return cnt<=m;
 } 
int main()
{
	
	while(scanf("%d%d%d",&L,&n,&m)!=EOF)
	{
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&d[i]);
		} 
		d[n+1]=L;
		sort(d+1,d+1+n);
		int l=1,r=L;
		while(l<=r) 
		{
			int mid=(l+r)/2;
			if(judge(mid))
			{
				ans=mid;
				r=mid-1;//继续往左找,直到找到最小的 (取左边区间);
			} 
			else
			{
				l=mid+1;
			}
		}
		printf("%d\n",ans);
	} 
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值