hdu 5826 physics (物理数学,积分)

physics

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 817    Accepted Submission(s): 454

Problem Description
There are n balls on a smooth horizontal straight track. The track can be considered to be a number line. The balls can be considered to be particles with the same mass.

At the beginning, ball i is at position Xi. It has an initial velocity of Vi and is moving in direction  Di.(Di1,1)
Given a constant C. At any moment, ball its acceleration Ai and velocity Vi have the same direction, and magically satisfy the equation that Ai * Vi = C.
As there are multiple balls, they may collide with each other during the moving. We suppose all collisions are perfectly elastic collisions.

There are multiple queries. Each query consists of two integers t and k. our task is to find out the k-small velocity of all the balls t seconds after the beginning.

* Perfectly elastic collision : A perfectly elastic collision is defined as one in which there is no loss of kinetic energy in the collision.
 
Input
The first line contains an integer T, denoting the number of testcases.

For each testcase, the first line contains two integers n <= 10^5 and C <= 10^9.
n lines follow. The i-th of them contains three integers Vi, Xi, Di. Vi denotes the initial velocity of ball i. Xi denotes the initial position of ball i. Di denotes the direction ball i moves in. 

The next line contains an integer q <= 10^5, denoting the number of queries.
q lines follow. Each line contains two integers t <= 10^9 and 1<=k<=n.
1<=Vi<=10^5,1<=Xi<=10^9
 
Output
For each query, print a single line containing the answer with accuracy of 3 decimal digits.
 
Sample Input
1
3 7
3 3 1
3 10 -1
2 7 1
3
2 3
1 2
3 3
 
Sample Output
6.083
4.796
7.141
 
Author
学军中学
 
Source
 
题目大意:

光滑的水平直线上有n个质量相等的小球,已知每个小球的初始位置,初始速度和方向,每个小球的每个时刻的加速度a都满足a*v=c,v是该时刻的速度,c是已知的

常数,小球之间的碰撞是完全碰撞(不明白就百度),然后q个询问,每次询问第t秒时速度第k小的小球速度是多少?

 

题解:

a = dv/dt = C/v

-----> vdv = Cdt

两边同时积分v是从v0-vt,t是从0到t

-----> [1/2*v^2] (v0---vt) = Ct  (0----t)

-----> v = sqrt(2*C*t+v0^2);

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
#include<vector>
using namespace std;

struct node
{
    double v,x,d;
}a[100005];

int T,n,q,t,k;
double c;

bool cmp(node a, node b)
{
    return a.v<b.v;
}
int main()
{
    scanf("%d",&T);
    for(;T>0;T--)
    {
        scanf("%d%lf",&n,&c);
        for(int i=1;i<=n;i++)
            scanf("%lf%lf%lf",&a[i].v,&a[i].x,&a[i].d);

        scanf("%d",&q);
        sort(a+1,a+1+n,cmp);
        for(;q>0;q--)
        {
            scanf("%d%d",&t,&k);
            double v=a[k].v;
            printf("%.3lf\n",sqrt(v*v+2*c*t));

        }
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/stepping/p/7204479.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值