HDU 5973 Game of Taking Stones 威佐夫博弈+大数

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5973

Game of Taking Stones


Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/65536 K (Java/Others)
问题描述

Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

输入

Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.

输出

For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

样例输入

2 1
8 4
4 7

样例输出

0
1
0

题解

威佐夫博弈+大数
对于a,b(a<b),如果有floor((b-a)*((sqrt(5)+1)/2))==a,则为必败态。

import java.awt.peer.SystemTrayPeer;
import java.math.BigDecimal;
import java.text.DecimalFormat;
import java.util.Scanner;  

public class Main {
    public static void main(String[] args) {  
        
        BigDecimal two=new BigDecimal(2);
        BigDecimal thr=new BigDecimal(3);
        BigDecimal fiv=new BigDecimal(5);
        
        BigDecimal l=two,r=thr;
        
        for(int i=0;i<500;i++){
            BigDecimal mid=r.add(l).divide(two);
            if(mid.multiply(mid).compareTo(fiv)<0){
                l=mid;
            }else{
                r=mid;
            }
        }
        
        BigDecimal gold=l.add(BigDecimal.ONE).divide(two);
        
        BigDecimal a,b;
        Scanner cin=new Scanner(System.in);
        
        while(cin.hasNext()){
            a=cin.nextBigDecimal();
            b=cin.nextBigDecimal();
            if(a.compareTo(b)>0){
                BigDecimal tmp=a;
                a=b;
                b=tmp;
            }
           
            BigDecimal zero=a.subtract(b.subtract(a).multiply(gold).setScale(0,BigDecimal.ROUND_FLOOR));
            
                //100位
            BigDecimal sma=new BigDecimal("0.00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
            
            if(zero.abs().compareTo(sma)<0){
                System.out.println("0");
            }else{
                System.out.println("1");
            }
            
        }
  
    }  
}

转载于:https://www.cnblogs.com/fenice/p/6036926.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值