hdu 5761 Rowe Bo 微分方程

1010 Rower Bo

首先这个题微分方程强解显然是可以的,但是可以发现如果设参比较巧妙就能得到很方便的做法。

先分解v_1v1​​,

Alt text

设船到原点的距离是rr,容易列出方程

\frac{ dr}{ dt}=v_2\cos \theta-v_1dtdr​​=v2​​cosθv1​​

\frac{ dx}{ dt}=v_2-v_1\cos \thetadtdx​​=v2​​v1​​cosθ

上下界都是清晰的,定积分一下:

0-a=v_2\int_0^T\cos\theta{ d}t-v_1T0a=v2​​0T​​cosθdtv1​​T

0-0=v_2T-v_1\int_0^T\cos\theta{ d}t00=v2​​Tv1​​0T​​cosθdt

直接把第一个式子代到第二个里面

v_2T=\frac{v_1}{v_2}(-a+v_1T)v2​​T=v2​​v1​​​​(a+v1​​T)

T=\frac{v_1a}{{v_1}^2-{v_2}^2}T=v1​​2​​v2​​2​​v1​​a​​

这样就很Simple地解完了,到达不了的情况就是v_1< v_2v1​​<v2​​(或者a>0a>0且v_1=v_2v1​​=v2​​)。

 

1011 Teacher Bo


考虑一种暴力,每次枚举两两点对之间的曼哈顿距离,并开一个桶记录每种距离是否出现过,如果某次枚举出现了以前出现的距离就输 YESYES ,否则就输 NONO .

注意到曼哈顿距离只有 O(M)O(M) 种,根据鸽笼原理,上面的算法在 O(M)O(M) 步之内一定会停止.所以是可以过得.

一组数据的时间复杂度 O(\min{N^2,M})O(min{N2​​,M}) .

 

 

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1248    Accepted Submission(s): 474
Special Judge


Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at  (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers  a,v1,v2.

0a1000v1,v2,100a,v1,v2 are integers
 

 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than  104, your solution will be accepted.
 

 

Sample Input
2 3 3 2 4 3
 

 

Sample Output
Infinity 1.1428571429
 

 

Author
绍兴一中
 
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int a,v1,v2;
    while(~scanf("%d%d%d",&a,&v1,&v2))
    {
        if(a==0) {printf("0.000\n");continue;}
        if(v1<=v2)
        {
            printf("Infinity\n");
        }
        else
        {
            double v=(v1*v1-v2*v2)+0.0;

            double ans=(a*v1*1.0)/v;
            printf("%.12lf\n",ans);
        }
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/superxuezhazha/p/5725033.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值