HDU 4046 Panda(树状数组)

Panda

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2838    Accepted Submission(s): 945


Problem Description
When I wrote down this letter, you may have been on the airplane to U.S. 
We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror. I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly. 

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn't know how many Saerdna's love there are in the letter.
Can you help Panda?
 

Input
An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.
The next m lines 
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R<n)
Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)
 

Output
For each test case, output the case number first.
The answer of the question.
 

Sample Input
 
   
2 5 2 bwbwb 0 0 4 0 1 3 5 5 wbwbw 0 0 4 0 0 2 0 2 4 1 2 b 0 0 4
 

Sample Output
 
   
Case 1: 1 1 Case 2: 2 1 1 0
 

Source


   题意:有一个长度为n的字符串序列,有两种操作   0 x y 输出x-y之间都多少个相邻的三个字符是wbw的字串。

  1 x c 将序列中位置为x上的字符改为c。



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 50001;

int n,m;
int c[N];
char str[N];

int lowbit(int x){
    return x&(-x);
}

int getsum(int x){
    int s = 0;
    while(x>0){
        s += c[x];
        x -= lowbit(x);
    }
    return s;
}

void add(int x,int y){
    while(x<=n){
        c[x] += y;
        x += lowbit(x);
    }
}

int main(){
    int T;
    scanf("%d",&T);
    int k = 0;
    while(T--){
        memset(c,0,sizeof(c));
        memset(str,0,sizeof(str));
        printf("Case %d:\n",++k);
        scanf("%d%d",&n,&m);
        scanf("%s",str);
        for(int i=1;i<n-1;i++){
            if(str[i-1] == 'w' && str[i] == 'b' && str[i+1] == 'w'){
                add(i,1);
            }
        }
        int x,y,z;
        char ss[10];
        while(m--){
            scanf("%d",&x);
            if(x == 1){
                scanf("%d%s",&y,ss);
                if(ss[0] == 'b'){
                    if(y-1>=0 && y+1<n && str[y] == 'w' && str[y-1] == 'w' && str[y+1] == 'w'){
                        add(y,1);
                    }
                    if(y-2>=0 && str[y-1] == 'b' && str[y] == 'w' && str[y-2] == 'w'){
                        add(y-1,-1);
                    }
                    if(y+2<n && str[y] == 'w' && str[y+1] == 'b' && str[y+2] == 'w'){
                        add(y+1,-1);
                    }
                }else if(ss[0] == 'w'){
                    if(y-1>=0 && y+1<n && str[y] == 'b' && str[y-1] == 'w' && str[y+1] == 'w'){
                        add(y,-1);
                    }
                    if(y-2>=0 && str[y] == 'b' && str[y-1] == 'b' && str[y-2] == 'w'){
                        add(y-1,1);
                    }
                    if(y+2<n && str[y] == 'b' && str[y+1] == 'b' && str[y+2] == 'w'){
                        add(y+1,1);
                    }
                }
                str[y] = ss[0];
            }else{
                scanf("%d%d",&y,&z);
                if(z-y<=1){
                    printf("0\n");
                    continue;
                }
                int sum1 = getsum(y);
                int sum2 = getsum(z-1);
                printf("%d\n",sum2 - sum1);
            }
        }
    }
    return 0;
}


转载于:https://www.cnblogs.com/gccbuaa/p/6903283.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值