poj1716——差分约束

poj1716——差分约束

Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13029 Accepted: 5516

Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.

Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.

Output

Output the minimal number of elements in a set containing at least two different integers from each interval.

Sample Input

4
3 6
2 4
0 2
4 7

Sample Output

4
题意:给定n个区间,求一个集合,每个区间都有两个数在集合里,求集合里的数的最小个数
思路:设s(x)为0-x中集合里的数的个数,则对区间[a,b],有s(b)-s(a-1)>=2,0<=s(i+1)-s(i)<=1;移项得s(b)-s(a-1)>=2,s(i+1)-s(i)>=0,s(i)-s(i+1)>=-1,符合dist[v]>=dist[u]+e,以此条件建图并松弛,求最长路即可,改为求最短路WA,不知道为什么。。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn=10010;
const int INF=(1<<28);

int N;
int a,b;
struct Edge
{
    int u,v,w;
};Edge edge[maxn*10];int e;
int Min,Max;
int dist[maxn];

void add_edge(int u,int v,int w)
{
    edge[e++]={u,v,w};
}

bool relax(int cur)
{
    int tmp=dist[edge[cur].u]+edge[cur].w;
    if(tmp>dist[edge[cur].v]){
        dist[edge[cur].v]=tmp;
        return true;
    }
    return false;
}

int bellman_ford()
{
    memset(dist,0,sizeof(dist));
    for(int i=Min;i<Max+1;i++){
        bool flag=0;
        for(int j=0;j<e;j++){
            if(relax(j)) flag=1;
        }
        if(!flag) break;
    }
    return dist[Max+1]-dist[Min];
}

int main()
{
    while(cin>>N){
        e=0;
        Min=INF;Max=-INF;
        for(int i=0;i<N;i++){
            scanf("%d%d",&a,&b);
            add_edge(a,b+1,2);
            if(a<Min) Min=a;
            if(b>Max) Max=b;
        }
        for(int i=Min;i<=Max;i++){
            add_edge(i,i+1,0);
            add_edge(i+1,i,-1);
        }
        cout<<bellman_ford()<<endl;
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/--560/p/4409690.html

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值