poj3159Candies——差分约束系统

poj3159Candies:http://poj.org/problem?id=3159

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 27345 Accepted: 7539

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

题意:班里共有n个人,现在要分糖吃,需要满足这样的条件:B同学得到糖的数量不能比A同学多K个。求flymouse(第n个)最多比snoopy(第1个)多几个糖。

由题意可得B-A<=K,建立A到B的边,权值为K,求出最短路即可。

需要注意的是用spfa+queue果真会超时,需要用spfa+stack。

另外,通过这题充分证明了用vector来存太慢了,非常非常慢........

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
#define INF 1000000007
#define maxn 50005

struct Edge
{
    int v;
    int w;
    int next;
} edge[maxn * 3];

int head[maxn],d[maxn],vis[maxn],n = 0,N;
void Add(int u,int v,int w)
{
    edge[n].v = v;
    edge[n].w = w;
    edge[n].next = head[u];
    head[u] = n ++;
}
  
void spfa()
{
    for(int i = 1; i <= N; i++)
        d[i] = INF;
    int q[maxn],top = 0;
    q[++top] = 1;
    d[1] = 0;
    while(top)
    {
        int v = q[top--];
        vis[v] = 0;
        for(int i = head[v]; i != -1; i = edge[i].next)
            if(d[edge[i].v] > d[v] + edge[i].w)   // 最短路径
            {
                d[edge[i].v] = d[v] + edge[i].w;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v] = 1;
                    q[++top] = edge[i].v;
                }
            }
    }
}
int main()
{
    int t,u,v,w;
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    scanf("%d%d",&N,&t);
    while(t --)
    {
        scanf("%d%d%d",&u,&v,&w);
        Add(u,v,w);
    }
    spfa();
    printf("%d\n",d[N]);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值