233 Matrix(hdu5015 矩阵)

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1190    Accepted Submission(s): 700


Problem Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

 

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

 

Output

For each case, output a n,m mod 10000007.
 

 

Sample Input

1 1
1
2 2
0 0
3 7
23 47 16
 

 

Sample Output

234
2799
72937
 
 
 
 
 

Hint

 

我们这样看:已知a11 ,a21 ,a31 ,a41  。。。求后面的

a12 = a11 +233;

a22 = a11 + a21 +233;

a32 = a11 + a21 +a31 +233;

a42 = a11 + a21 +a31 +a41 +233;

.........

 

同理:后面的列也一样:

a13 = a12 +233;

a23 = a12 + a22 +233;

a33 = a12 + a22 +a32 +233;

a43 = a12 + a22 +a32 +a42 +233;

...........

 

ss所以有矩阵:

233a11 
a21 a31 a41 ...3

*

101111...0
01111...0
00111...0
00011...0
00001...0
.....................
10000...1

=

......................................................................................................................................................

 

 

z转载请注明出处:寻找&星空の孩子

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5015 

 

#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
#define mod 10000007

LL N,M;

struct matrix
{
    LL m[15][15];
};
LL a[15];

matrix multiply(matrix x,matrix y)
{
    matrix temp;
    memset(temp.m,0,sizeof(temp.m));
    for(int i=0; i<N+2; i++)
    {
        for(int j=0; j<N+2; j++)
        {
            if(x.m[i][j]==0) continue;
            for(int k=0; k<N+2; k++)
            {
                if(y.m[j][k]==0) continue;
                temp.m[i][k]+=x.m[i][j]*y.m[j][k]%mod;
                temp.m[i][k]%=mod;
            }
        }
    }
    return temp;
}

matrix quickmod(matrix a,LL n)
{
    matrix res;
    memset(res.m,0,sizeof(res.m));
    for(int i=0;i<N+2;i++) res.m[i][i]=1;
    while(n)
    {
        if(n&1)
            res=multiply(res,a);
        n>>=1;
        a=multiply(a,a);
    }
    return res;
}
int main()
{
    int n,k;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        a[0]=233;
        a[N+1]=3;
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&a[i]);
        }

        matrix ans;
        memset(ans.m,0,sizeof(ans.m));
        ans.m[0][0]=10;
        ans.m[N+1][0]=1;
        ans.m[N+1][N+1]=1;
        for(int j=1;j<=N;j++)
        {
            for(int i=0;i<=j;i++)
            {
                ans.m[i][j]=1;
            }
        }

        ans=quickmod(ans,M);//M次幂定位到纵坐标。

        LL ant=0;
        for(int i=0;i<N+2;i++)//横坐标是N,即,乘以矩阵的N列。
        {
            ant=(ant+a[i]*ans.m[i][N])%mod;
        }
        printf("%I64d\n",ant);
    }
    return 0;
}

 

 

本来要做新题的,可是遇到不会的了。。。hdu4767 Bell 现在卡在  中国剩余定理,还要好好梳理梳理!

 

加油!少年!!!                                                 

 

转载于:https://www.cnblogs.com/yuyixingkong/p/4343064.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值