Trailing Zeroes (I) LightOJ - 1028(唯一分解 因子个数)

Trailing Zeroes (I) LightOJ - 1028

题目链接:https://vjudge.net/problem/LightOJ-1028

题目:

We know what a base of a number is and what the properties are. For example, we use decimal number system, where the base is 10 and we use the symbols - {0, 1, 2, 3, 4, 5, 6, 7, 8, 9}. But in different bases we use different symbols. For example in binary number system we use only 0 and 1. Now in this problem, you are given an integer. You can convert it to any base you want to. But the condition is that if you convert it to any base then the number in that base should have at least one trailing zero that means a zero at the end.

For example, in decimal number system 2 doesn't have any trailing zero. But if we convert it to binary then 2 becomes (10)2 and it contains a trailing zero. Now you are given this task. You have to find the number of bases where the given number contains at least one trailing zero. You can use any base from two to infinite.


Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer N (1 ≤ N ≤ 1012).

Output

For each case, print the case number and the number of possible bases where N contains at least one trailing zero.

Sample Input

3

9

5

2

Sample Output

Case 1: 2

Case 2: 1

Case 3: 1

Note

For 9, the possible bases are: 3 and 9. Since in base 3; 9 is represented as 100, and in base 9; 9 is represented as 10. In both bases, 9 contains a trailing zero.

题意:说给一个10进制数,让你转化成任意进制的数,该数末位为0,有几种方案?

思路:其实当该十进制数模这个进制时为0时,那么转化后的数最后一位都为能,所以这题相当于就是求有多少个因子,用唯一分解求就行了因子个数为(1+a1)(1+a2)(1+a3)...,a1,a2,a3为质因数的指数,注意因子数要减一,因为1进制无意义的

//
// Created by hanyu on 2019/8/11.
//
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
using namespace std;
const int maxn=1e6+1000;
typedef long long ll;
int prime[maxn],isprime[maxn];
ll len;
void getp()
{
    memset(isprime,0,sizeof(isprime));
    for(int i=2;i<maxn;i++)
    {
        if(!isprime[i])
        {
            for(int j=i*2;j<maxn;j+=i)
            {
                isprime[j]=1;
            }
        }
    }
    for(int i=2;i<maxn;i++)
    {
        if(!isprime[i])
            prime[len++]=i;
    }
}
ll fenjie(ll n)
{
    long long int ans=1;
    for(int i=0;i<len&&prime[i]*prime[i]<=n;i++)
    {

        if(n%prime[i]==0)
        {
            int num=0;
            while(n%prime[i]==0)
            {
                num++;
                n/=prime[i];
            }
            ans*=(1+num);
            if(n==1)
                break;
        }
    }
    if(n>1)
        ans*=2;
    return ans-1;
}
int main()
{
    getp();
    int T;
    scanf("%d",&T);
    int casee=0;
    ll n;
    while(T--)
    {
        scanf("%lld",&n);
        printf("Case %d: %lld\n",++casee,fenjie(n));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Vampire6/p/11336756.html

基于SSM框架的智能家政保洁预约系统,是一个旨在提高家政保洁服务预约效率和管理水平的平台。该系统通过集成现代信息技术,为家政公司、家政服务人员和消费者提供了一个便捷的在线预约和管理系统。 系统的主要功能包括: 1. **用户管理**:允许消费者注册、登录,并管理他们的个人资料和预约历史。 2. **家政人员管理**:家政服务人员可以注册并更新自己的个人信息、服务类别和服务时间。 3. **服务预约**:消费者可以浏览不同的家政服务选项,选择合适的服务人员,并在线预约服务。 4. **订单管理**:系统支持订单的创建、跟踪和管理,包括订单的确认、完成和评价。 5. **评价系统**:消费者可以在家政服务完成后对服务进行评价,帮助提高服务质量和透明度。 6. **后台管理**:管理员可以管理用户、家政人员信息、服务类别、预约订单以及处理用户反馈。 系统采用Java语言开发,使用MySQL数据库进行数据存储,通过B/S架构实现用户与服务的在线交互。系统设计考虑了不同用户角色的需求,包括管理员、家政服务人员和普通用户,每个角色都有相应的权限和功能。此外,系统还采用了软件组件化、精化体系结构、分离逻辑和数据等方法,以便于未来的系统升级和维护。 智能家政保洁预约系统通过提供一个集中的平台,不仅方便了消费者的预约和管理,也为家政服务人员提供了一个展示和推广自己服务的机会。同时,系统的后台管理功能为家政公司提供了强大的数据支持和决策辅助,有助于提高服务质量和管理效率。该系统的设计与实现,标志着家政保洁服务向现代化和网络化的转型,为管理决策和控制提供保障,是行业发展中的重要里程碑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值