D - How Many Tables (并查集)(水题)

点击打开链接



Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

这个为什么TEL

Select Code
#include <stdio.h>
#include <string.h>
#define Maxn 1005
int par[Maxn],count=0;
void init(int n)
{
	for(int i=0; i<n; i++)
	par[i]=i;
}
int find(int x)
{
	int r=x;
	while(par[r]!=r)
	{
		r=par[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=par[r];
		par[r]=i;
		i=j;
	}
	return r;
}

void join(int x, int y)
{
	int fx=find(x), fy=find(y);
	if(fx!=fy)
	{
		par[fx]=fy;
		count++;
	}
}
int main()
{
	int i,j,a,b,n;
	scanf("%d",&n);
	while(n--)
	{
		count=0;
		scanf("%d%d",&a,&b);
		init(a);
		while(b--)
		{
			scanf("%d%d",&i,&j);
			join(i,j);
		}
		printf("%d\n",a-count);
	}
	
	
	return 0;
}

AC代码



Select Code
#include <iostream>  
#include<cstdio>  
#include<cmath>  
#include<cstring>  
  
using namespace std;  
  
int pre[1100];  
  
int findset(int v)  
{  
    int t1,t2=v;  
    while(v!=pre[v])    v=pre[v];  
    while(t2!=pre[t2])  
    {  
        t1=pre[t2];  
        pre[t2]=v;  
        t2=t1;  
    }  
    return v;  
}  
  
void unions(int x,int y)  
{  
    int t1=findset(x);  
    int t2=findset(y);  
    if(t1!=t2)  pre[t1]=t2;  
}  
  
int main()  
{  
    int T,n,m;  
    cin>>T;  
    while(T--)  
    {  
        cin>>n>>m;  
        for(int i=1;i<=n;i++)   pre[i]=i;  
        for(int i=0;i<m;i++)  
        {  
            int u,v;  
            scanf("%d%d",&u,&v);  
            unions(u,v);  
        }  
        int ans=0;  
        for(int i=1;i<=n;i++)  
            if(pre[i]==i)   ans++;  
        cout<<ans<<endl;  
  
    }  
}  









转载于:https://www.cnblogs.com/ruruozhenhao/p/7406508.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值