How Many Tables (并查集)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

思路

这道题用到了并查集的思想。并查集可以算是一个相对比较简单的算法吧。这道题我的代码是用了两个数组,第一个是用来记录他们彼此间是否认识的,而第二个数组是用来记录同一桌的人数有多少个。而题目的要求只让我们求有多少桌就行了,而这里的一桌有多少人有多少个可以不用管它,只是借助这个数组来计算一共有多少桌就好了。

#include <iostream>
#include <stdio.h>
#include <cstring>

using namespace std;
int t,n,m,fx,fy;
int a[1005],b[1005];

void sets(int n)
{
    for(int i=1;i<=n;i++)
        a[i]=i;
}
int finds(int x)
{
    while(a[x]!=x)
    {
        x=a[x];
    }
    return x;
}
int main()
{
    scanf("%d",&t);
    for(int q=0;q<t;q++)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d %d",&n,&m);
        sets(n);
        for(int i=0;i<m;i++)
        {
            int j,k;
            scanf("%d %d",&j,&k);
            fx=finds(j);
            fy=finds(k);
            a[fx]=fy;
        }
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            if(b[finds(a[i])]++==0)
                sum++;
        }
        cout<<sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值