POJ1056 IMMEDIATE DECODABILITY【数据结构】

题目地址:http://poj.org/problem?id=1056


Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Source

Pacific Northwest 1998

将各个编码序列作为二叉树的节点序列建立二叉树,并在过程中标记编码序列的最后一位,然后遍历二叉树,如果存在非叶节点的istail为1,即可说明存在某序列为另一序列的前缀序列。

#include <stdio.h>
#include <stdlib.h>

typedef struct btree{
	int istail;
	struct btree * left;
	struct btree * right;
}BTree, *pBTree;

char data[11];
BTree * root = NULL;

void insert(char data[]){
	int i= 0;
	BTree * p = NULL;
	if (root == NULL){
		root = (BTree *)malloc(sizeof(BTree));
		root->istail = 0;
		root->left = root->right = NULL;
	}
	p = root;
	while (data[i] != '\0'){
		if (data[i] == '0'){
			if (p->left != NULL){
				p = p->left;
			} else{
				p->left = (BTree *)malloc(sizeof(BTree));
				p = p->left;
				p->istail = 0;
				p->left = p->right = NULL;
			}
		} else{
			if (p->right != NULL){
				p = p->right;
			} else {
				p->right = (BTree *)malloc(sizeof(BTree));
				p = p->right;
				p->istail = 0;
				p->left = p->right = NULL;
			}
		}
		++i;
	}
	p->istail = 1;
}

int isImmediately(BTree * root){
	BTree * p = root;
	while (p != NULL){
		if (p->istail == 1 && (p->left != NULL || p->right != NULL))
			return 0;
		else
			return isImmediately(p->left) && isImmediately(p->right);
	}
	return 1;
}

void destoryBTree(pBTree * root){
		if ((*root)->left)
			destoryBTree(&(*root)->left);
		if ((*root)->right)
			destoryBTree(&(*root)->right);
		free(*root);
		*root = NULL;
}

int main(void){
	int count = 0;
	while (gets(data)){
		if (data[0] == '9'){	
			if (isImmediately(root))
				printf("Set %d is immediately decodable\n", ++count);
			else
				printf("Set %d is not immediately decodable\n", ++count);
			destoryBTree(&root);
		} else{
			insert(data);
		}
	}

	return 0;
}


转载于:https://www.cnblogs.com/liushaobo/p/4373729.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值