POJ 1035 Spell checker(字符串简单匹配)

Spell checker

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 12900

 

Accepted: 4760

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i

is

has

have

be

my

more

contest

me

too

if

award

#

me

aware

m

contest

hav

oo

or

i

fi

mre

#

Sample Output

me is correct

aware: award

m: i my me

contest is correct

hav: has have

oo: too

or:

i is correct

fi: i

mre: more me

Source

Northeastern Europe 1998

 解题报告:这道题就是字符串匹配问题,分为四种情况,(1)完全匹配,(2)字符串长度相同只是只有一个字母不相同(3)字符串相差一,比原始字符串少一个字符或多一个字符;

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int N = 10010;
char word[N][20];
int Judge1(char *a, char *b, int len)
{
int i, ans = 0;
for (i = 0; i < len; ++i)
{
if (a[i] != b[i])
{
ans ++;
if (ans > 1)
{
return 0;
}
}
}
return 1;
}
int Judge2(char *a, char *b, int len)//len是字符串a的长度;
{
int i, j, ans = 0;
for (i = 0, j = 0; i < len; ++i)
{
if (a[i] != b[j])
{
ans ++;
j --;
if (ans > 1)
{
return 0;
}
}
j ++;
}
return 1;
}
int main()
{
int i, count, flag, len1, len2;
char c[20];
memset(word, 0, sizeof(word));
count = 0;
while (scanf("%s", word[count]) && strcmp(word[count], "#") != 0)
{
count++;
}
while (scanf("%s", c) && strcmp(c, "#") != 0)
{
printf("%s", c);
flag = 1;
for (i = 0; i < count; ++i)
{
if (strcmp(c, word[i]) == 0)//完全匹配情况
{
printf(" is correct\n");
flag = 0;
break;
}
}
if (flag)
{
printf(":");
len1 = strlen(c);
for(i = 0; i < count; ++i)
{
len2 = strlen(word[i]);
if (len1 == len2 && Judge1(c, word[i], len1))//长度相同,只有一个字符不匹配
{
printf(" %s", word[i]);
}
else if ((len1 - len2 == 1) && Judge2(c, word[i], len1))//长度相差一,比原始字符串多一个
{
printf(" %s", word[i]);
}
else if ((len2 - len1 == 1) && Judge2(word[i], c, len2))//长度相差一,比原始字符串少一个
{
printf(" %s", word[i]);
}
}
printf("\n");
}
}
return 0;
}



转载于:https://www.cnblogs.com/lidaojian/archive/2012/03/14/2396658.html

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值